1

I have a bunch of hosted zones set up for some GoDaddy domains. Also, my website is a WordPress website hosted on an Elastic Beanstalk environment.

  • I've imported the record sets from the GoDaddy domains into my hosted zones
  • Replaced the GoDaddy nameservers with the ones from the hosted zones
  • Set up a "www" alias for my Elastic Beanstalk application in each of the hosted zones

The domain names successfully redirect to my website, but the domain in the URL is still my ugly Elastic Beanstalk one instead of the set up domain name.

I'm stumped. Could this possibly be a WordPress issue?

UPDATE:

After messing around with different URL's I noticed that typing a link to a specific page on the site with one of the Domains I set up works! No elastic beanstalk domain. However, I did this with my website open in another tab while logged in as admin. The strange thing is that I wasn't logged in on the new tab so it seems the user sessions are not the same between my domains. This could just be how it works, though (I'm new to this).

  • What do you have the site URL set to in your wordpress settings? See codex.wordpress.org/Changing_The_Site_URL – Stephen Ostermiller Jan 18 '18 at 0:00
  • That is what I've been messing with now. It is set to my EBS URL currently because every time I try to change it, I get a "TOO_MANY_REDIRECTS" error from the browser. @StephenOstermiller – Seb G Jan 18 '18 at 15:55
  • You need to to clear your browser cache every time you change it. What is likely happening is that your browser already has the redirect cached from your domain to beanstalk. Then when you change it the browser gets a redirect from beanstalk to your domain and gets in an infinite loop from the cache. – Stephen Ostermiller Jan 18 '18 at 16:18
  • OK its working for the homepage now. I have to change a bunch of links in my code but other then that its all set. Thank you! – Seb G Jan 18 '18 at 16:40
  • Unfortunately a new problem has occurred. I've posted it here if you have any idea, please let me know. – Seb G Jan 18 '18 at 21:22
1

The problem was changing "Site URL" to the correct URL and then clearing my browser cache.

This can be done in admin>settings>general.

| improve this answer | |
0

no, this is not a wordpress issue. You need to open a tab incognito and navigate to your domain url after waiting 24 - 48 hours for the DNS records to propagate. This will insure google isn't using cached data to push you over to the site.

If that doen't work, you need to show us what your DNS records look like (without sensitive info of course), so that we can better diagnose your issue.

| improve this answer | |
  • If it is doing redirects, it sounds like the DNS is pointing to the right place. I think it is a server or wordpress configuration issue rather than a DNS issue. – Stephen Ostermiller Jan 18 '18 at 0:01
  • Thanks for the info! I set all of this up well over 2 weeks ago so DNS should definitely be fully propagated. I did contact AWS support and they mentioned that they spotted Apache 301 permanent redirects. I never set any of these up so I'm wondering if it is somewhere within the Wordpress configuration files. I cannot find any though. Also, I have updated my question above with some possibly vital info. – Seb G Jan 18 '18 at 14:20
  • no proble, bud. I think @StephenOstermiller is right about this one. – Michael Henderson Jan 18 '18 at 14:22
  • Do you have any recommendation what to to do to narrow down the configuration issue? – Seb G Jan 18 '18 at 14:27
  • @SebG do you have ssh access to the server ? Also, did you manually install and setup Apache yourself ? – Michael Henderson Jan 18 '18 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.