6

I currently run a Plesk VPS, with 2 Domains hosted within.

Some time ago, I had installed the 'Let's Encrypt' SSL Certificate onto my Plesk VPS. Both domains, successfully displayed the 'https' prefix within the domain and I was able to use the emails with no problems, within Outlook 2016.

Recently, I have started to receive the following 'Internet Security Warning' whenever I try to add new emails into Outlook 2016.

I have spoken with Plesk, my hosting company. Microsoft and Let's Encrypt, with all parties stating differing errors, explaining I need to speak with the other party.

Is anyone able to point me in a possible direction, as to resolve this issue?

enter image description here

  • Is it a subject alternative name (SAN) certificate? Based on the error message it sounds like outlook 2016 may not support alternate names. It sounds like it is only looking at the main (principal) name. – Stephen Ostermiller Jan 17 '18 at 2:06
  • Are you hosting mail on your VPS, or are you using Plesk's shared mail services? If you are using shared services you probably need to change your mail server settings to use something like mail.plesk.tld rather than mail.mydomain.tld. See: msoutlook.info/question/613 – Stephen Ostermiller Jan 17 '18 at 2:11
  • I am hosting the emails within both domains, on the same VPS. Not sure if this would be an issue but I have entered 'mail.domain.com' into the DNS Records. Would I need to create a sub domain for this to work? I have no problems sending and receiving emails, just want to ensure I get the certification set up correctly. – Craig Jan 17 '18 at 2:18
1

I have managed to resolve the issue.

Step One:

When you first see the 'Internet Security Warning', select 'View Certificate'.

enter image description here

Step Two:

What you then need to do, is identify who the Certificate has been issued to. Refer to the below image, for where to find this information. Once you have identified the location, copy the entry exactly as is.

enter image description here

Step Three:

Head into your Outlook and then head into File > Account Settings > Account Settings. You should then be on a page, which looks something like:

enter image description here

Simply select one of your emails by double clicking on the relevant account.

Step Four:

Referring to Step Two, simply paste in the 'Issued to' information into the Incoming mail server and Outgoing mail server(SMTP) text boxes, as highlighted in the below image.

enter image description here

Step Five:

All that is left to do now, is to click 'Next' and continue as you would normally. Then repeat the process for the other emails.

Where I was going wrong, was that I had mail.domain.com entered into the Incoming and Outgoing server text boxes. This was ok for a while, since I hadn't installed an SSL Certificate onto my server but now that I have an SSL Certificate, I needed to change my entries, to reflect the name of my server, which the SSL Certificate was installed on.

protected by Community Feb 1 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.