2

I use the W3 Total Cache Plugin for Wordpress.

If I enabled "Cache SSL (https) requests" in W3 Total Cache and testing my site at https://securityheaders.io for security reports, then I get only one time a positive response.

Anyone know I can fix that?

The problem is when I disabled the SSL Caching the 304 header (Last-Modified) don´t works anymore.

If I clear the cache then it works again and the response is positive. But i can´t clear the cache every time after an request for every user.

Or I have a wrong thought ?

migrated from security.stackexchange.com Jan 13 '18 at 10:53

This question came from our site for information security professionals.

  • 1
    Could you elaborate on how the result is negative the second time? – jrtapsell Jan 12 '18 at 22:26
  • CSP, X-Frame Options, X-Content Options, XXS, Referrer Policy. But on my page the browser still declares the site as safe. – rgcapo Jan 13 '18 at 4:46
  • @rgcapo Where is the cache being stored? On your server disk, memory, or on a third party CDN like CloudFlare? Also can you post the response headers you get from uncached and cached pages? (Look in Dev Tools, Network tab, click the first thing listed.) – DisgruntledGoat Jan 13 '18 at 14:04
  • Thanks for answer! Cache stored on server disk. In Chrome Dev Tool, Network Tab only are timecounts, nothing else. I disabled now the whole PageCache and enabled only Browser Caching and it works fine. But isn´t it possible to cache with PageCache and SSL? – rgcapo Jan 15 '18 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.