1

I moved my website from HTTP to HTTPS version month ago, and I made all necessary changes, I made 301 redirect so all old links redirect to the HTTPS version, and I added the new version to webmaster tools, submitted a new sitemap, and made all needed changes to my site, also changed all internal links to HTTPS, after that everything was just fine my site links in google changed to HTTPS and the visits to the HTTP version become fewer every day, but I was surprised when I saw my links in google changed to http again after that and visits to HTTP version rise day by day as you can see in the pic, 301 redirect working perfectly, now what I have to do to make the links appear in HTTPS version in google? any one can help me ?

enter image description here

  • Have you removed the old sitemap from the http version and also updated your robots.txt to represent the new sitemap url ? – Randomer11 Oct 25 '17 at 15:28
  • thank you for replying, no i didn't removed the old sitemap because experts in google productforums saying it's better to keep them for few weeks, and i have updated robots firle to https version – M.Elghdban Oct 25 '17 at 17:14
  • Are you sure you set up all your redirects properly? Also for the homepage? Have you added Strict Transport Security header? – tobiv Oct 26 '17 at 11:05
  • @tobiv Hi, all pages redirecting perfectly, i use Cloudflare ssl, i found out that i didn't activate 2 options (HSTS) and Automatic HTTPS Rewrites i think this is the cause of the problem do you agree ? – M.Elghdban Oct 26 '17 at 16:18
  • Yes, if you activate these options you should be good. – tobiv Oct 26 '17 at 18:59
2

use the .htaccess to force redirect to https, so that every visitor (including Google's index, gets the correct version):

Add this to the top of your .htaccess file:

RewriteEngine On RewriteCond %{HTTP_HOST} ^example.com [NC] RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]

*be sure to replace www.example.com w/ your domain name, same goes for example.com

1

If all the links are redirected properly then you should have no traffic on the http pages.

Looks like this is a screenshot from Search Console. Did you set the preferred version of your site to the https version in SC site settings?

  • In Google Search Console, you are able to specify which version of the domain is the preferred one. You might have four domain properties to choose from if you set them all up. https/http/www/non-www – Yan Gilbert Oct 26 '17 at 19:34
  • ah i get you, i tried to find this option but i couldn't see it in Search Console, – M.Elghdban Oct 26 '17 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.