3

We have recently improved the lazy loading of images on our site, but are now experiencing some anomalies in Fetch and Render.

The issue is that although the view that Googlebot sees is correct and renders exactly as the user seesit, the view that claims to be as the user sees it is not. It's all correct until you get towards the bottom of the view, where some of the images are not shown, this is intermittent.

It is the same images that fail to render, if the do fail at all, but only one or two out of many. These images have nothing untoward about them and are all small and optimised.

There are cases when the entire page is not rendered, but again this is intermittent. My thoughts were that as the page loads, there are no events to tell Google that everything that the page requires has finished, so there is a delay between resources at which point they deem it complete. If this were the case however, I would expect the whole page to show, but possibly unstyled. Again, this is not the case.

Is this something that is common or seen at all, and is it something that we should be concerned about, seeing as the Googlebot view is correctly shown?

2

Lazy loading images was once a problem, but I've not seen many cases of it being an issue in the last 18 months. It has obvious benefits such as faster loading times, knock on effects such as better user experiences and so forth.

If you look at the source with "fetch with Google" , rather than looking at hte render does it show all image code , along with their alt attributes etc ? if so consider it a rendering bug imo.

As a fall back though you could wrap your images in such practices as <noscript> or escaped fragments as mentioned here :

https://www.idea-r.it/blog/110/en/lazy-loading-seo-problem

  • 1
    or just use .no-js img { display: block; } .js img { display: none; } – Simon Hayter Oct 11 '17 at 22:26
  • Thanks for the advice. I don't think that there's an issue with the JavaScript as most of the images load, just a few at the bottom. Much of the page is driven by JS and all of that is rendering as expected. My suspicion is that the renderer that shows what the user should see is not parsing the page correctly, as the Google view and the actual view in the browser are identical, as expected. – Orbittman Oct 13 '17 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.