I just installed Drupal. But after installation I can't see my installed site.

Upon visiting the URL http://localhost/drupal-7.0/ in my browser I do not get the web page as expected but see files and directories similar to FTP file browsing.

Can someone explain what I have done wrong?

  • @xralf: By install you mean you went through the setup wizard, right? Also, did you will these directions, drupal.org/documentation/install
    – blunders
    Mar 21, 2011 at 12:18
  • Installation was according to INSTALL.txt file and it was without problems.
    – xralf
    Mar 21, 2011 at 12:29

1 Answer 1


The problem here is that your website isn't set up to serve index.php as the default index file.

Check the DirectoryIndex configuration entry of Apache.

  • My files are in /var/www directory. Drupal is in /var/www/drupal-7.0 directory. In /var/www I have only index.html file. Could you tell me where is the index.php file, or should I create it? And where is the configuration file with DirectoryIndex? thank you
    – xralf
    Mar 21, 2011 at 12:53
  • The index.php file should already exist in drupal-7.0 direcory. The apache configuration is dependant on your operating system distribution - they all differ.
    – Majenko
    Mar 21, 2011 at 12:59
  • It was my fault. I initially copied the files to /var/www and then I moved them to /var/www/drupal-7.0. And in the folder /var/www was the file index.php (I learned php before a month) and I overwritten it and forgot to move to /var/www/drupal-7.0. My distribution is Xubuntu (Lucid Lynx). I have a directory /etc/apache2 but don't know in which file to find it.
    – xralf
    Mar 21, 2011 at 13:14
  • On mine (Ubuntu 10.10) it's in /etc/apache2/mods-enabled/dir.conf
    – Majenko
    Mar 21, 2011 at 13:24
  • 1
    When you're moving a drupal site from one directory to another, always pay attention to the .htaccess file. It it hidden by default, so it will not be moved along with the rest if you just Select All -> Copy -> Paste in your file manager. Mar 23, 2011 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.