1

Our email marketing system tracks clicks by appending a unique string after links within the email i.e. www.example.com/buy-now?tracking1 & www.example.com/buy-now?tracking2 etc.

The problem is: if a user views their email in the web browser, clicks on a link and then navigates back (via the browser button) to the email, the link no longer works. Refreshing the web page after the user has clicked through also breaks.

This doesn't show a 404 but a "This site can't be reached" error

This specific email links to multiple websites and there's only one site where this is happening.

Is this something that can be addressed via the .htaccess file?

  • 2
    Can you give us an example of a real URL that only works the first time? "This site can't be reached" sounds more like a network error. I can't imagine that a tracking parameter would cause that. – Stephen Ostermiller Oct 3 '17 at 17:26
  • 1
    I didn't get a network error. I got the error (in Firefox): "Content Encoding Error -- The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression." – Stephen Ostermiller Oct 4 '17 at 9:19
  • 1
    I also see this comment at the bottom of the page: <!-- Dynamic page generated in 1.034 seconds. --> <!-- Cached page generated by WP-Super-Cache on 2017-10-04 10:24:46 --> <!-- Super Cache dynamic page detected but late init not set. See the readme.txt for further details. --> That makes me think that this Super Cache plugin is the problem, or at least part of the problem. – Stephen Ostermiller Oct 4 '17 at 9:27
  • 1
    I get an error page even if I switch browsers. It doesn't appear to be cookie or client related. It appears that it is getting cached on the server side incorrectly. More evidence pointing to your cache plugin. – Stephen Ostermiller Oct 4 '17 at 9:44
  • 1
    Chrome does say it is a network error, but the specific reason is ERR_CONTENT_DECODING_FAILED. – Stephen Ostermiller Oct 4 '17 at 9:45
1

As Stephen Ostermiller identified, the issue was caused by a Wordpress caching plugin (WP-Super-Cache)

To fix the issue:

Go to Settings > Advanced > Then tick the box saying Don’t cache pages with GET parameters. (?x=y at the end of a url)

enter image description here

  • Other forums indicate that you can solve this by either removing the plugin or disabling gzip compression in Apache. If you could figure out which settings in the cache plugin can be used to avoid this plugin, your post would be a more useful resource than anything else out there on the internet about this. – Stephen Ostermiller Oct 4 '17 at 11:32
  • Another possibility is to install a different WordPress caching plugin. I usually install the "W3 Total Cache" plugin in WordPress and I haven't seen his error from it. – Stephen Ostermiller Oct 4 '17 at 11:33
  • I have experimented and found the specific option for fixing this issue. Answer updated. – Double Clicked Oct 4 '17 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.