2

I've just set up CloudFlare for my website, so that I can run HTTPS (yes, I know it's not encrypted end-to-end... this is fine). All the images, script resources, etc. are now linked using protocol-agnostic URLs, but I'm still not getting the green 'Secure' indicator in Chrome's address bar.

This is because Blogger is injecting their nav/header bar into my pages, and that bar includes a search form with an action attribute of "http://www.example.com/" (no HTTPS)

I can't use CloudFlare to rewrite it because it's not being served from my own host. I've tried hiding it using CSS but this doesn't remove the warning. There's no explicit option I can find anywhere in the Blogger admin to configure or remove this header/search bar.

It's a fragment of HTML inside an IFRAME; before I start hacking around with all sorts of complicated JavaScript to try and intercept the iframe and stop it loading, is there a cleaner way of doing this? I'm happy with the search form targetting https://, I'm happy to remove the search form - or even the entire nav bar - from the page; I just want to get rid of the mixed-mode security messages and get my green padlock... any ideas?

3

...and, of course, within 2 minutes of posting the question, I've found it.

Log into Blogger, Layout, Navbar, Edit, and there's an option to switch the navbar off.

D'oh.

  • Thanks for sharing! It is the way. You can struggle for days and days and finally in desperation and frustration you post a question and Wha La! You find the answer! It happens to all of us. Cheers!! – closetnoc Jul 27 '17 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.