I have a blogger account and wished to use a custom domain address which I managed to buy and setup using Cloudflare. I enabled flexible SSL and used "always HTTPS" page rules. Now when i was setting up some templates for my blog, i noticed some errors.

On using custom domain name, certain gadgets or components on the blogger don't work. They simply vanish even if you have changed nothing on the template[ you just uploaded theme and simply use custom domain, you can see this issue]. What is quite frustrating is if you revert back to demo.blogspot.com, everything seems to work fine.

I tested to number of templates at least 6+ on different variation but this didn't seem to resolve.

  • 1
    Likely the gadgets and components are requiring resources that aren't being served under HTTPS. You can view them in the Dev Tools mode of your browser (e.g., in Chrome, errors will be listed in the Console tab). You'll either need to find a way to run those resources under HTTPS, or use another template that fully supports HTTPS. Questions seeking troubleshooting for individual sites are unfortunately considered off-topic here since they're unlikely to help future visitors.
    – dan
    Commented Jul 25, 2017 at 4:20
  • It appears there is legitimate conflict between the scripts that cloudflare uses and blogger. Thank you dan for the quick reply, however i would like to request you to not put on hold as i tested this with another domain on cloudflare. If we use https redirect in the blogger, there is no issue. Just a concern on the Cloudflare and Blogger. I was also suggested to not to use Cloudflare for some other issue as well. There is something wrong with this JS invoke and Blogger ajax.cloudflare.com/cdn-cgi/-----------/cloudflare.min.js,
    – cdrrazan
    Commented Jul 25, 2017 at 4:27
  • What does the Dev Tools report? In Cloudflare, try disabling "Auto Minify" for everything listed there, and disable Rocket Loader if enabled. Also be sure to purge the cache files under Cache, and delete the cache in your browser too before loading the page again. Have a look at the following help doc from them: How to Enable SSL on Tumblr, WordPress, Blogger, AppEngine, Posterous & More.... If there continues to be an issue, open up a support ticket with them.
    – dan
    Commented Jul 25, 2017 at 4:46
  • It seems from the comments in their help doc that others are having issues with mixed content (e.g., resources being served from HTTP and HTTPS) when using Blogger. Perhaps this article might help (skip down to "Fixing Mixed Content Errors After Moving to HTTPS").
    – dan
    Commented Jul 25, 2017 at 4:52
  • N.P. Since it's a general issue after all, and not specific to a template, I'll reopen the question. After you get a handle on the information, maybe you can answer your question below with a brief description and accept it when you can. It might be helpful to others, and you'll earn some reputation points for doing so. Thanks.
    – dan
    Commented Jul 25, 2017 at 4:58

1 Answer 1


Certain gadgets comes broken whenever Autominify option is enabled via Speed > Auto Minify in the Cloudflare Panel. The issue also arises whenver Rocketloader [ Speed > Rocketloader ] is turned on.

Turn off rocketloader and/or uncheck on HTML,CSS, Javascript on autominify option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.