2

Because of misbehavior of our old hoster justhost.com, our domains including victorporton.com do not act as they should.

But justhost.com ignores our queries saying that they can't help because our account with them is terminated. (They forgot to remove our DNS information, however.)

The correct IP to which the DNS must point is 176.9.146.215.

I wrote to Verisign asking to take an action against justhost, but my email was not answered. What else can be done?

Below there is a description of technical conditions:


Our nameservers are pointing to ns1.kleinburdhost.com and ns2.kleinburdhost.com.

When we try to resolve the domain victorporton.com the following happens:

$ dig @a.gtld-servers.net victorporton.com ... ns1.kleinburdhost.com. 172800 IN A 74.220.195.44 ns2.kleinburdhost.com. 172800 IN A 69.89.16.124

Note that it has returned the wrong IPs.

These IPs are from their nameserver:

$ dig @74.220.195.44 ns1.kleinburdhost.com ... ns1.kleinburdhost.com. 60 IN A 74.220.199.15

$ dig @74.220.195.44 kleinburdhost.com ... kleinburdhost.com. 60 IN A 74.220.199.15

Note that two last dig queries to your nameserver return wrong IPs.

When resolving the IP for ns1.kleinburdhost.com the nameserver 74.220.195.44 uses its parent server kleinburdhost.com (which has a wrong IP in this response) and when resolving the IP for kleinburdhost.com it uses the nameserver ns1.kleinburdhost.com or ns2.kleinburdhost.com (which also have wrong IPs in this response).

Thus it happens a vicious circle: The top level domain servers such as a.gtld-servers.net use nameservers ns1.kleinburdhost.com or ns2.kleinburdhost.com with wrong IPs to resolve kleinburdhost.com and to resolve ns1.kleinburdhost.com or ns2.kleinburdhost.com servers it uses their parent kleinburdhost.com with wrong IPs is used. This leads to the fact that both ns1.kleinburdhost.com, ns2.kleinburdhost.com, and kleinburdhost.com are queried with wrong IPs.

  • Can't you just delegate the domain to your new provider (through your domain registrar's control panel)? Whether or not your old host still hold DNS records is then irrelevant. – Tim Fountain Jul 20 '17 at 9:55
  • What @TimFountain says. Change the name server (NS) records at your domain registrar to point to the name servers for your new host. Then your old host will be completely ignored. – Stephen Ostermiller Jul 20 '17 at 10:06
  • It also isn't clear from your question exactly who owns what. Who owns the ns1.kleinburdhost.com dns servers? Is that your old host, your new host, or you? – Stephen Ostermiller Jul 20 '17 at 10:08
  • Another way to solve the problem would be to use the DNS servers of your registrar. For example if you GoDaddy, you can use NS records for Goddady's servers and put the A record into GoDaddy's DNS server: godaddy.com/help/add-an-a-record-19238 – Stephen Ostermiller Jul 20 '17 at 10:10
  • 2
    That clears some things up. You shouldn't ever need to own your name servers. You should just use somebody else's name servers. Doing so is far more reliable. Switch the name server records from ns1.kleinburdhost.com to the values given to you by either your web host or your registrar. – Stephen Ostermiller Jul 20 '17 at 12:20
1

ns2.kleinburdhost.com is a glue inside .com registry, registered by eNom with IP 176.9.146.219, same for ns1 with IP 176.9.146.215

If this is not the IP you want you will need to go through eNom to make this value be changed at the registry. But this seems to be correct IPs now based on your question.

Note that using glues, why not super advanced DNS mastery, is still prone to errors, so this should be used carefully.

  • You described the problem (which we knew) not the solution. Well, anyway we have already solved the problem by communicating with the hoster. – porton Nov 25 '17 at 22:27
  • Thanks for your very useful comment, that makes helping you very desirable. You never realised you add a glue and what that entails, at least from your question (and I am not sure you are understanding the problem even now so you may risk to encounter it again in the future), and you did never update your question here to say your problem is resolved, in order to let people stop trying to help you. Post your "solution" as an answer here and accept it to close the question, thank you in advance! – Patrick Mevzek Nov 25 '17 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.