I am trying to move my site to a different provider. The mail server I am using at the moment I want to keep. My DNS management is done at a different service. I am trying to figure out what the right settings are but somehow I am keep getting this wrong.

Original working settings with site and mail server at the same location

Note: In this example i use 99.999.999.99 as the IP for the website server. I use 88.888.888.88 as the IP for the mail server (and old website server).

A   *.example.com   →   88.888.888.88   
A   example.com     →   88.888.888.88   
A   localhost.example.com   →   
MX-10   example.com     →   mail.example.com    
CNAME   imap.example.com    →   example.com     

Now I moved the website to a new server (99.999.999.99) and changed the DNS like this. I created a CNAME and an A record for mail.example.com. Now the site is working but I can not send mails.

A   *.example.com   →   99.999.999.99   
A   example.com     →   99.999.999.99   
A   localhost.example.com   →   
A   mail.example.com    →   88.888.888.88   
MX-10   example.com     →   mail.example.com    
CNAME   imap.example.com    →   example.com     
CNAME   www.example.com     →   certainserver.com   

I guess I need to add some record for the IMAP. But I don't know to what. Does it need an A record for the Imap?

  • I'm not sure why you added the CNAME for www. Shouldn't www point to your new server (99.999.999.99)? Jul 11, 2017 at 16:35
  • Have you tried changing the CNAME for imap to point to mail.example.com? It seems likely to me that all mail related domains should point to the old server. You changed the imap subdomain to point to your new server. Jul 11, 2017 at 16:36
  • Who is hosting the DNS management? Jul 11, 2017 at 16:55
  • And also... was your email provided by the same company who provided the DNS? since sometimes you need to use different MX records when accessing using different name servers. Jul 11, 2017 at 17:05
  • Can you elaborate on "cannot send mail"? What happens when you try to send? This is important information because there are many different things that can go wrong with email, and so the more clarification you can give, the better the answers will be and the more easily people will be able to find the question if it's relevant to them.
    – DKing
    Jul 11, 2017 at 18:41

1 Answer 1


The MX for your site is mail.domain.com is it not?

You seem to be a bit confused about IMAP. IMAP and POP are different ways for a mail program to work with a mail server. These terms have nothing to do with your MX setup. So why are you using an imap.domain.com NS record?

If mail is coming in and going out from the same server, simply point outgoing mail to the same mail server as incoming - in this example mail.{domain}.com

The only time you would need to have a separate NS record for outgoing mail is if you were using an entirely different server in which case it would need to be an A record, and standard nomenclature for outgoing mail servers is smtp.{domain}.com

  • True, I am a bit confused. The CNAME for Imap was allready present. So actually this should be working using the right settings? Jul 11, 2017 at 14:43
  • Yes your mail should work simply by using mail.{domain}.com There is no need for imap.{domain.com} as it serves no purpose.
    – garth
    Jul 11, 2017 at 14:49
  • If you have mail clients currently configured to use the imap subdomain, that would be a good reason to keep it. Jul 11, 2017 at 16:37
  • If you want people to use the imap. subdomain for mail then it should be setup the same way as mail. currently is... with an A record and a separate MX record as authoritative for the root domain, and either remove the mail. subdomain or specify a higher preference setting such as 0 for the imap. subdomain MX record. (Mark the question as answered if you have your solution).
    – garth
    Jul 13, 2017 at 0:10
  • The configuration is working as a pop3 now. Also sending mail is working. IMAP is not working at the moment. I am still working on that. Jul 13, 2017 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.