2

Recently one of my web sites shows in Google results but the url connected with the Google result is from another website in my server. so i have url-A and url-B

So when i hit url-A in google , I would expect my Google result to be url-A/some-page-from-site-A and instead i get:

url-B/some-page-from-site-A

This is happening for url-A with 3 more web sites url-C/some-page-from-site-A url-D/some-page-from-site-A url-E/some-page-from-site-A

When i hit the link i get a

"Your connection is not private Attackers might be trying to steal your information from url-B (for example, passwords, messages or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID"

I submitted the links to Google and waiting for removal but i'd like to know what has happened and how can i avoid such incidents.

All web sites are mine and under the same server

6
  • Have you got SSL certs for both sites? Are they running from the same IP address? – L Martin May 23 '17 at 9:47
  • the affected web site has https:// the others dont. they all run from the same ip yes – xbass540 May 23 '17 at 10:04
  • Which is the default host for the IP? Assuming you attempt on port 80. – L Martin May 23 '17 at 10:07
  • these all are web sites in my shared hosting plan and they all share an ip: 104.244.xxx.xxx . I hope this answers your question – xbass540 May 23 '17 at 10:09
  • which site comes up if you do: http:// 104.244.xxx.xxx/, just trying to gauge if this is SNI related with your cert, or if it's an indexing issue with Google. – L Martin May 23 '17 at 10:11
1

There's a few things that can cause indexing issues with Google that could be in play here:

  • If you're running more than one site with SSL/TLS enabled on a single IP Googlebot can get confused when attempting to connect on port 443. It may be your server is returning just the HTTPS enabled site, despite hostname requests for others coming in via SNI in the handshake. To test this, try connecting on port 443 for the other domains and see what happens. Check host config and make sure it's issuing certs for other domains based on the request (so visit https://another-domain.com/ and check it's not just the same cert for yours).

  • There are occasionally index issues with same IP pages if you're using relative links. Use absolute links on your page, so Google isn't picking up href '/some-page' instead it sees 'http://your-domain.com/some-page'. Check your HTML and host configuration to make sure requests on 443 aren't being resolved to the wrong page. To fix this, it appears when your pages have enough backlinks Google seems to correct itself then. I assume because it can later verify links using external sources.

3
  • Could you please explain how to connect to port 443 or the rest. I'd like to mention that this is a shared host so i dont have any root access or so. You think that this might be a miscofiguration of the hosting company? What should i ask them do? There is this possibility because i just moved to a new one. Relative to your second bullet: these are all Joomla Web sites the urls are dynamically generated so i have little control. – xbass540 May 24 '17 at 10:48
  • port 443 is HTTPS. Port 80 is HTTP. It's as simple as making sure those protocols preface the domain name in your address bar. – L Martin May 24 '17 at 11:36
  • i got an answer from the hosting company that they didnt install a dedicated ip for the url-A web site so it gets confused with all the other web sites of the server. It goes for the https protocol (SSL is installed) but because doesnt have a dedicated ip it falls back to the other web sites in the server. Now i am installing dedicated ip and wait to see if the issue is resolved. I wonder if i need to ask google to remove the wrong results or they will be removed through time? – xbass540 Jun 4 '17 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.