1

I have a problem with Google's Search Console.

When I "Fetch as Google" and status is Complete, I click on "Request Indexing", fill in the Captcha and Submit.

Nothing happens after i click on Submit, i see a loading circle for a split second and then I still have the submit window as if I didn't fill it.

Why this? Thank You in advance

  • Have you tried clearing the cache in your browser, or using another browser? – dan Apr 27 '17 at 23:09
  • Thank you @dan♦ for your answer. Yep tried both cache clearing and other browser (Opera and Firefox). Nothing happened. – Alessandro Berrone Apr 27 '17 at 23:23
  • Does the Captcha have a green arrow like this? Do you have any noindex directives in your meta tags or server header - or is there a disallow directive in your robots.txt for that URL(s)? Lastly, what does it say under Search Console > Google Index > Index Status? – dan Apr 27 '17 at 23:39
1

I think you may be forgetting to click a radio button for "Crawl only this URL" or "Crawl this URL and its direct links". You need to select one of those two options before the "Go" button works:

Once you click the "Go" button, then the dialog disappears and "Indexing requested" appears in the "Status" column where the "Request indexing" button used to be:

If it still doesn't work for you, I'd suggest trying different browsers: Firefox, Chrome, Safari, and Edge. Whichever alternates you have available.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.