2

I have a problem with already indexed URLs (100k URLs). I have correct the pages with noindex and canonical tags over a month but old indexed pages aren’t removed from results.

The problem is the URL parameters that have already been indexed. I think that Google will never crawl URLs from old category pages with many URL parameters.

Also, I can see many indexed URLs with errors:

?pg=25&error_message=Unknown%2BSSL%2Bprotocol%2Berror%2Bin%2Bconnection%2Bto%2Bapi.twitter.com%3A443

How is it possible to remove these kind of URLs? Only with Remove URLs tool? Google will not crawl nonexistent pages.

I have already uses the “Fetch as Google” and resubmit sitemap.

  • As long as you are returning a noindex and canonical tag with these pages, there is nothing for you to do. It can take quite some time for Google to remove these pages. You will simply have to be patient. Updating your sitemap was a good thing too. I am would think that if these pages were linked that might help. If they are not linked, I am not sure I would work too hard to link them. Cheers!! – closetnoc Apr 4 '17 at 16:33
  • Have you changed the URL structure? ie. there is a "new" category that you should be redirecting to? Just to clarify, is error_message=Unknown%2B... part of the indexed URL? – MrWhite Apr 4 '17 at 20:15
  • Thank you for your answers I don’t have change url structure but the error_message has been indexed. I assume that Google will not crawl again the url with the error message so it will not read the new noindex tag. So for urls with the error_message i must remove them manually from Removal tool in webmaster? Is there any penalty for too many removal request? For the urls that I have add noindex and I want google to re-crawl I need to add them in a robot.txt file to help google crawl faster? – Aris Gasteratos Apr 5 '17 at 10:10
1

To remove the URLs with error messages from Google search, I would log into Google Search Console for your site and use the URL parameters tool. Add the parameter error_message. It is an active parameter because it changes the page. Then set it to No URLs so that Google won't crawl and index them.

You can also update your robots.txt file with the lines:

User-Agent: *
Disallow: *error_message*
Noindex: *error_message*

Once Google knows not to crawl and index these pages, they should fall out of the search results within a few weeks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.