3

I'm working on building my first website in a non-corporate environment. When I go to http://example.com it works fine. But when my friend tried, they found that GoDaddy forces HTTPS everywhere and got a cert error. Then the got a generic page about "Future home of something quite cool." (it forwards to a cgi folder of some sort).

Is there a way to disable this behavior? If at all possible, I don't want to pay for a SSL certificate if I can avoid it. The page just displays some basic stuff for my school work. I don't collect customer data, so I don't think SSL is necessary.

I'm using Linux hosting with CPanel right now. Though that can change easily enough. Any help is greatly appreciated!

  • 1
    Just for clarity, you've registered your domain with GoDaddy and are using them for hosting as well? Is your friend using a browser extension that forces HTTPS everywhere? You could add a redirect to your web server's config (using a .htaccess file) that would redirect all requests to HTTP, but visitors using browser extensions might get caught in a loop if they're only requesting HTTPS (depending on how the extension is coded). The easiest and likely most reliable solution in this case is to add CloudFlare, which will provide a free Flexible SSL. – dan Apr 2 '17 at 23:16
  • BTW, if you want to try using a redirect first, if it's just a few friends viewing your site and don't want to add CloudFlare (not very difficult to do), follow the directions here, but substitute the .htaccess code from the accepted answer here (there isn't a GoDaddy Help doc for that since most people usually want to do the opposite). – dan Apr 2 '17 at 23:25
  • 1
    @dan To implement an HTTPS to HTTP redirect on the server you would still need an SSL cert installed - otherwise you get stuck on the same browser warning as before. – MrWhite Apr 3 '17 at 7:37
  • "because they force HTTPS everywhere" - How do they force HTTPS everywhere? Is it simply a browser extension, as Dan suggests, or a network-wide policy? For GoDaddy to apparently serve adverts off the default SSL page is just bad on GoDaddy's part IMO. – MrWhite Apr 3 '17 at 8:02
  • 1
    @w3dk That's not an advert, that's GoDaddy's default hosting page, which users get redirected to whenever an index file is missing, or their hosting isn't configured with an SSL properly. Adding a redirect in cPanel to an available resource prevents default redirects. Also, they can use domain forwarding in their domain control panel to forward to HTTP, which occurs prior to cPanel. However, if visitors use a browser extension that repeatedly request the HTTPS version, they might get stuck in a loop then. – dan Apr 3 '17 at 9:03
2

Yes, you can disable HTTP to HTTPS redirect by modifying the .htaccess files just remove the following code from your .htaccess file.

RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}

Also, you are able to get a free SSL certificate from Let's Encrypt

Cpanel has a plugin that you are able to install using the command line on the server.

There also other ways that you can get a free Let's Encrypt certificate if you don't have command line access to your server.

  • Not able to see htaccess file in cpanel. Trying from 2 days but same error. – Md Mohsin Feb 25 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.