1

Hi I have Apache server on Centos and installed the latest stable version of mod_pagespeed module.

I'm noticing that it automatically adds browser caching of 365 days to all my image, css files etc! It's overriding my browser cache directives on my .htaccess file as well. I confirmed this by disabling the mod_pagespeed to off and checked for browser caching and none were 365 days then.

How do I specify in pagespeed.conf to stop browser caching my files? There is an option extend_cache I tried disabling that option but it's not working.

Please assist. Thanks!

6
  • Did you purge the cache once you had disabled extend_cache? Commented Mar 28, 2017 at 17:23
  • Purge which cache modpagespeed? If so what's the best way to purge the modpagespeed cache? Thanks Commented Mar 28, 2017 at 17:24
  • So I tried adding the following in mod_pagespeed pagespeed.conf file:ModPagespeedModifyCachingHeaders off ModPagespeedDisableFilters extend_cache Commented Mar 28, 2017 at 18:48
  • The settings above just don't work! it keeps browser caching for 365 days! Commented Mar 28, 2017 at 18:49
  • That's not how you flush the CACHE. Settings does not flush your CACHE, you need to manually do that via the command line. Refer to Pagespeed documentation. Commented Mar 28, 2017 at 22:26

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.