2

I have wordpress site with domain domain.com and on one site i use font icons. The problem is when I change in settings Address site (URL) on www.domain.com. Sites works properly, I seu www in URL but font icons doesnt work (it shows blank square instead).

I want to have either i type domain.com or www.domain.com in browser url that the site show up with www and icon fonts will works

httaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I'm using wp svg icons

Without www

enter image description here

With www in settings

enter image description here

The problem is that this is not affecting only this wp svg icons plugin but also others

  • 1
    Sorry but there is not enough information to be able to answer your question without speculating. We have no information of the fonts you are using nor how they are being loaded when a visitor visits the sites, if you have updated the WordPress Address and the Site Address found in settings > general etc. Also if you have ever edited .htaccess it would be ideal to add that too. Sharing the site address sometimes helps too, in short... we need more information. – Simon Hayter Feb 10 '17 at 12:40
  • I found this in web console: downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:3): bad URI or cross-site access not allowed source: (here is url without www) – user3590388 Feb 10 '17 at 14:53
  • Ok, i found a solution i set only website address with www and i had to set wordpress address with www also – user3590388 Feb 10 '17 at 14:57
  • Which I suggested if you have updated the WordPress Address and the Site Address found in settings > general etc – Simon Hayter Feb 11 '17 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.