I just recently acquired and installed a SSL certificate, but my HTTPS links are as slow as can be. My website went from consistent 1.4-1.9 second load times to 3-3.9 second load times. It actually loaded in less than a second with lower quality images in the home page. My current host is HostGator Cloud, which is relatively fast.

Just to be clear, I am forcing HTTPS (and also fixing WP partially encrypted errors) by using a 301 Redirect via WordPress plugins. I would doubt that these are causing the issues, considering that I have disabled them and noticed less than a 20ms difference for HTTPS load times.

My website is currently significantly slower than my competitors using HTTPS; They are seeing between 1.6 and 1.9 seconds, and I am seeing 3+. Why are my load times twice as long when they have MORE requests and a similar amount of data to load?!

Thanks for your help guys.

  • I am more concerned that you website is running slowly in general. Your 1.6-1.9 seconds times seem slow to me. It could be that HTTPS is exacerbating an existing problem. Cheers!!
    – closetnoc
    Feb 2, 2017 at 20:16
  • Edit: I see what you mean; my website uses decent quality images and is graphics based on the home page. That shouldn't be too big of an issue though, regardless, right? HTTPS should not be adding 2 seconds of "wait" time. Right? All of my issues for HTTPS load times are considered "wait" time on Pingdom. None of my plugins or anything have any issues.
    – Eric
    Feb 2, 2017 at 23:27
  • You are right. Without seeing first hand, I am not sure how I can help. There are others that know SSL enough to at least get you started in that direction. High quality images will slow the down load times significantly and can be the reason for your original load times.
    – closetnoc
    Feb 2, 2017 at 23:58
  • I would like provide my website in hopes that it will help anyone interested: ejbpools.com
    – Eric
    Feb 3, 2017 at 0:18
  • That may help in this case.
    – closetnoc
    Feb 3, 2017 at 0:20

1 Answer 1


I will note a few things here that may be of interest when it comes to your page load time...

Number of Files
A quick check of the developer tools shows that your site is download close to 70 separate static files to the browser which is made up of javascript files, css files, image files, etc. Now given the types of images you are using there is not a huge amount you can do about the images other than reducing their site somewhat where possible however when it comes to the javascript and CSS files it would well suit you to combine a number of them into single files (for instance move all your javascript into one file or at the very most a very small number of related files grouping code together by function). You can also look at combining all of the CSS into one file.

Time to First Byte
Overall your site has a TTFB of 2.29 seconds which is exceedingly long. The TTFB is how long the browser is waiting until it gets the first byte of a file. This is most often affected by server response time and by the latency of the round trip.

Now your SSL handshake is only taking around 250ms which is reasonably good so the issue would seem to be to do with the TTFB. Given the fact that you state you are using HostGator cloud it would sound like either the server instance you are using does not have sufficient resources to run the WordPress installation (unlikely but possible) or more likely a plugin in your WordPress installation is slowing things down. You have to bare in mind that the WordPress application has to finish going through the code before the HTML is sent to the browser. Best diagnostics you can do at this point is to disable all extensions possible so that you are running a plain vanilla WordPress installation. Once you have done that try loading and see what the TTFB is showing then. If it is still high (anything over around 160ms can be improved upon) then you may need to look at improving the server instance you are on (high ram or CPU depending on what is choking the code up). If it is good then slowly re-enable each extension and plugin one at a time until you find the one that is causing the degradation in your TTFB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.