1

I have successfully installed Let's Encrypt SSL certificates on my server after going though some issues.

You can view my issues being treated by their awesome team in there official site: https://community.letsencrypt.org/t/i-ran-this-command-certbot-auto-and-got-this-error-no-vhost-exists-with-servername-or-alias/26136

Problem is that my website, which is a vBulletin Forum due to some issue is not applying the security to it!

Here is what I was told:

The "problem" here is that you have a redirect/rewrite rule redirecting https to http, pay attention to below output from your server, you will see a Location header redirecting

https://www.iforumelite.com to http://www.iforumelite.com/forum.php?s=7c01b777432f8d66d2f927f5d848aa88

He mentioned:

Note: The redirect/rewrite rule could be in your apache conf, on .htaccess files used by your site or even the forum that you are using could be redirecting it.

I checked all of it and found nothing. Here is my .htaccess file for the site in question:

RewriteEngine on

# If you are having problems or are using VirtualDocumentRoot, uncomment this line and set it to your vBulletin directory.
# RewriteBase /forum/

# If you are having problems with the rewrite from content/ to content.php, uncomment this line to turn MultiViews off.
# Options -MultiViews

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

# Forum
RewriteRule ^threads/.* showthread.php [QSA]
RewriteRule ^forums/.* forumdisplay.php [QSA]
RewriteRule ^members/.* member.php [QSA]
RewriteRule ^blogs/.* blog.php [QSA]
RewriteRule ^entries/.* entry.php [QSA]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

# MVC
RewriteRule ^(?:(.*?)(?:/|$))(.*|$)$ $1.php?r=$2 [QSA]

# Check MVC result
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^(.*)$ - [NC,L]
RewriteRule ^(.*)$ - [R=404,L]

# Set PHP handler to application/x-httpd-php on Fri Nov 13 19:59:33 MST 2015.
#AddHandler application/x-httpd-php .php
3
  • 3
    I suspect you have not informed your CMS of the URL change, since most content management systems use PHP redirects from a set base URL normally set in the database or a config file. Login to your dashboard and check your settings within and perhaps the config file that is used to connect to the database. – Simon Hayter Jan 28 '17 at 18:31
  • how can I mark your comment as my answer! :) – Hugo Jan 28 '17 at 23:31
  • Added as answer. – Simon Hayter Jan 29 '17 at 11:15
1

I suspect you have not informed your CMS of the URL change, since most content management systems use PHP redirects from a set base URL normally set in the database or a config file. Login to your dashboard and check your settings within and perhaps the config file that is used to connect to the database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.