3

After I installed and turned on a SSL certificate, I began to receive 310 errors. The site is built with nopcommerce.

SSL Settings on the site are all included:

enter image description here

4
  • 1
    Have you tried clearing your browser cache? That can sometimes fix this type of problem. Commented Jan 24, 2017 at 15:37
  • I'd clear the browser cache, or switch to a different browser to test. I've encountered these issues many times and a forced refresh usually solves it. I went to the site and I don't get the error you are getting. I would also suggest forcing https, which you are not doing right now. Commented Jan 24, 2017 at 18:32
  • @PatrikAlienus , Now redirect disabled. The error appears when the redirection is enabled
    – WebMorda
    Commented Jan 30, 2017 at 15:02
  • @WebMorda In other words, there is some piece of code that's adding a resource with http:// instead of https://. Commented Jan 30, 2017 at 20:12

1 Answer 1

2

The problem was solved by adding a line to the file WebConfig

<add key="Use_HTTP_X_FORWARDED_PROTO" value="true" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.