3

I have recently upgraded my Wordpress site to https and i have noticed that the Yoast SEO plugin generates sitemaps that have URLS defined as http. Is this incorrect for a https site and if so is there anyway to flip it over to https?

Thanks

5

You need to disable and reenable the sitemap, going to SEO > Sitemap XML. It probably will solve your problem (Yoast bug).

2

Yoast SEO uses the default site address set by your WordPress installation which is entered the first time you install WordPress. When enforcing a HTTPS on a WordPress set you must setup the current URL on both the WordPress Address and Site Address URL options found within the Dashboard in General Settings.

  1. Login to your WordPress Dashboard
  2. Click Settings
  3. Click General

Then your options should look something like this:

enter image description here

If you have these settings already in place then its likely your hosting is caching the current file which needs purging.

1

You might need to check your wp-config file. Some managed wordpress hosts or people that harden wordpress for solid security reasons will set the url in wp-config. If that doesn't match up to what it should in mysql or your wordpress settings, that can cause this issue. (and make changing it in wordpress or the database feel impossible)

1

In my case, it worked only like this. Adding to wp-config.php

define('WP_HOME', 'https://xxxxxxxxxx.com'); define('WP_SITEURL', 'https://xxxxxxxxxx.com');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.