4

I recently updated my Wordpress site to https but i didnt get the padlock next to the name in the browser and it says that it is insercure. I investigated using the following site:

https://www.whynopadlock.com/check.php

and it appears my Logo and Favicon images are coming from a http address. Is there anyway to set these to https?

Thanks

3 Answers 3

4

You are likely going to find they are hard coded http:// in your theme's header.php file.

If not, check in the customisation menu under site identity. You may have to remove and re-add your favicon.

3
  • 1
    It is worth adding to this that you should check a site that has shifted to https in either the developer tools > console in Chrome or I am sure there is a site that will check your site to make sure all content is being called over https:// You may be surprised to find out how many http:// resources are hard coded and causing a warning.
    – Steve
    Jan 16, 2017 at 7:15
  • It was not hardcoded. it has some variables there. Even after removing and adding again still gives http. Nov 3, 2018 at 6:07
  • A straightforward solution is the Really Simple SSL plugin. Works well
    – Steve
    Jul 11, 2020 at 14:35
3

I had the same problem. On the Settings->General page, there are two fields, "WordPress Address (URL)" and "Site Address (URL)", that had http in them instead of https. I update those fields and the problem went away.

1

I know this is an old thread, but I have found this issue today. checked the "Wordpress Address (URL)" and "Site Address (URL)" fields and these were both showing as https://, however within the actual options table, the entries were stored with just plain http://

Updating these two fields resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.