2

One of my inherited projects has the domain name being added to all relative path dimensions in all of my Google Analytics reports.

Google Analytics Page Report

I've looked into a few things but I'm not 100% positive if this is on the Google Analytics side or the JavaScript code side.

Their property settings appear to be all correct. I did notice their own domain is not in their Referral Exclusion List, so maybe they accidentally removed it. Would that cause this issue?

Their filters do seem to be set up incorrectly, and they do have a Find/Replace filter- but it's only set to find "^www." in the hostname and the replace field is empty. I wouldn't think that this filter would append the data to the path, but maybe it does? According to the Filter Verification this would not have altered any data.

I'll probably be making a handful of changes to this Google Analytics setup, but I wanted to ask to see what could be causing something like this (maybe there is also something else I'm not thinking of).

1
  • I assume you are using WordPress? I say this because this sounds familiar. It is likely a setting change that has to be made for your site. Not sure. Not a WP person. Sorry. However, I do like the question. I hope you get an answer soon. Cheers!!
    – closetnoc
    Dec 15 '16 at 19:38
1

There are times when it is a setting on WP and Joomla but as of a few years ago, Google has been in fact doing this since at least 2012, but I see it happening more often than not. One thing that has stood out is they tend to do it on Titles that are short

Sometimes they add your URL to the end of a title tag.

As mentioned some have title tags that are short and have a URL at the end. In some cases Google is adding a URL on top of that. Looks like this.....

Keywords at Example.com | eexample.com

Sometimes they replace your title tag with words that match the query.

One person wrote.

I object to this because they have overwritten a title tag that with my marketing message such as "free shipping" or a kickass price that pulls in buyers.

One quick way to see how you are showing up is search site:yourSiteName and see in indeed your pages are showing up as such by Google.

Then do the same at Bing/Yahoo. Most likely you are not hacked and you will not see the same happening at Bing/Yahoo.

1

I was able to go through and change the view settings, filters, and referral exclusion list and it has fixed the problem.

If I was more patient I could have made the changes one at a time, but I can confirm that in this case (even though this is a WordPress site) it was all on the Google Analytics side (and not the website side). Not 100% positive which of the above fixed it, though.

If anyone else has this issue, here's exactly what I did:

  • View Settings (View): I emptied the "Default Page" field. When creating a new view, this is empty to begin with, but at some point somebody put their domain in there.
  • Filters (View): They had a find/replace filter in place (Find "^www." in the hostname and replace with nothing), but the verification said it wouldn't affect any traffic, so I'm thinking it was a red herring. I removed it along with some other improper filters.
  • Referral Exclusion List (Property): It looks like they were attempting to block ghost spambots using this, so I removed the "spambot" domains from the list. They were also missing their own domain. Basically, I emptied this list, and then added their domain to it (which is how it should be by default).
    • For reference, I added a "Valid Hostname" include filter on this view to only allow data from traffic to their domain (and acceptable others).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.