2

This is my first time using the Google Cloud Launcher to host WordPress.

I paid someone from Upwork to configure all of this in order to save time. Not sure they did it properly. I see none of the A records from Google in my DNS settings below:

Google Console Custom Domain Settings

DNS settings

I can access the site at work, and others can access the site as well. When I try and access the URL from my home computer, I get an error in my browser:

404 Not Found Error: Not Found The requested URL / was not found on this server.

I've tried resetting the router and modem, and clearing the cache in my browser.

What might be the problem?

  • I am not sure how log it has been since setting DNS, however, it can take time to propagate to all of the DNSs throughout the Internet. As well, some ISPs cache settings for a period. I have seen 1 week and as much as 1 month which is horrible. This is not all ISPs of course. Just a few here and there. I do not believe in caching DNS, however, I can see the notion of saving network bandwidth for stuff that does not change. My question would be, Have you waited long enough? Cheers!! – closetnoc Dec 8 '16 at 1:41
  • I hear you. It's been several days and the URL is accessible via the Philippines, India and 20 miles from my home at work...but not from my house. ARG! – Marc Trimble Dec 8 '16 at 3:27
  • Frustrating I am sure! Several days should normally do it. Like I say, some ISPs will cache DNS. Even the big ones. AT&T (if I remember right) was famous for this at one point. It's a horrible practice. You can always use nslookup or some other tool to see what you get. (from home of course) Cheers!! – closetnoc Dec 8 '16 at 3:44
  • @MarcTrimble Looks like your DNS is with GoDaddy. Both Google and GoDaddy are pretty quick to update their DNS. Your site didn't resolve for me on a major ISP, but did on with several online DNS tests and browser screenshot sites. I'm seeing a few errors being returned, particularly for your SOA record. I'd suggest contacting GoDaddy's DNS department and explain that your DNS is still not resolving to Google's cloud servers after several days, they're pretty good about sorting things out. Unfortunately there's not much we can do for you here. – dan Dec 8 '16 at 3:44
  • Thank you so much guys! I appreciate the insights and knowledge!! – Marc Trimble Dec 9 '16 at 22:48