1

I'm installing SSL in many websites, almost all of those don't give me any problem at all, but some of them do.

One of the sites uses a 3rd party weather script on a remote server that does not use HTTPS://

EDIT: My website is not detected as insecure page, instead, it loads without any problem but browsers blocks the widget, so it doesn't print any content (it should print an iframe)

1

Sorry to be the bearer of bad news but the issue is with your site and there's no way to prevent a obviously intended notification. The notification informs users that the site is not fully secure, which its not if you are using 3rd party scripts over HTTP. If you want to solve the problem then you must use HTTPS:// on all local and external resources.

So if you want users knowing that your site is fully secure and you want Google to reward a bit of SEO value to the site because of it, then you must either have them upgrade to SSL or ditch the widget all together... there is no workaround for this issue... Also rather than using https:// you should opt to use //example.com/image.jpgif the site is accessible via both protocals.

Your three options are:

  1. Remove the widget.
  2. Accept the notification
  3. Ask them to upgrade the API service to HTTPS.
  • Alright, that's exactly was I though :/ I will lead with it, thanks! – Mc Kernel Nov 25 '16 at 9:03
1

There is another solution - as mentioned here on the Google developers site Short: you could either use upgrade-insecure-requests - which will result in the non-https widgets not being displayed (quote:if the resource is not available over HTTPS, the upgraded request fails and the resource is not loaded. This maintains the security of your page)- it's not supported by all browsers however. Alternative is to use block-all-mixed-content - which will block all insecure content (even if it's inside an iframe) - not very sure about browser support.

Haven't used either one - but could be worth checking.

  • For some reason, that's what my site already does, maybe I didn't described exactly my issue, question already edited, however, I was asking for keep my page secure and get the widget to work, but I already saw that's not possible. Anyways, nice answer, I will keep it in mind for possible future issues, thanks! – Mc Kernel Nov 25 '16 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.