1

I have a VPS in one provider (Provider A), and I have set the email server all works ok. in another provider (Provider B) I have the domain registered. So, let's assume it is mydomain.com

On the provider B: I had created a subdomain called mail.mydomain.com, configured the dns as follow:

HOST         Type    Result
(empty)      A       123.123.123.123
www          A       123.123.123.123
mail         A       123.123.123.123

Then on mail exchange records I've configured as follow:

HOST            Priority   Result
(empty)         30         123.123.123.123

On the subdomain mail.mydomain.com, I have configured the dns as follow:

HOST         Type    Result
(empty)      A       123.123.123.123
www          A       123.123.123.123
  • 1
    An A record on mail.mydomain.com set to your IP, a MX record on mydomain.com set to mail.mydomain.com and you probably also wanna set up two TXT records: DKIM and SPF… – wb9688 Oct 24 '16 at 6:36
  • ok I will try but, so I don't need pop.mydomain.com, or smtp.mydomain.com? then on gmail for example, should I just use always mail.mydomain.com independently of the protocol? – sudo.ie Oct 24 '16 at 9:40
  • ok tried all that, did dig +short mail.mydomain.com, ip is correct, but telnet on ports 587, 465, 25 none of them connects.. – sudo.ie Oct 24 '16 at 10:10
  • Yep, just mail.mydomain.com for SMTP, IMAP and POP. Have you actually set up your mail server and opened that ports on a firewall? – wb9688 Oct 25 '16 at 14:03
1
  1. Set up your mail server(s) to listen at mail.mydomain.com
  2. Make sure your firewall doesn't block your mail server(s)'s ports
  3. Set an A record on mail.mydomain.com pointing to your IP address
  4. Set a MX record on mydomain.com pointing to mail.mydomain.com
  5. It should be working, but you probably wanna set up DKIM, DMARC and SPF
  • it does not fix my issue, but it is certain the way DNS should be set. – sudo.ie Oct 25 '16 at 15:26
  • @sudo.ie: So, what's your issue? – wb9688 Oct 26 '16 at 15:07
  • all seems ok, but it still not work, so dns seems to point ok, mail server looks ok, firewall lookgs ok, but when I try to connect to mail.mydomain.com on any email port, it does not connect. – sudo.ie Oct 26 '16 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.