Tweeted twitter.com/StackWebmasters/status/658016513073532928
2 Inline code formatting, removed signature/thanks.
source | link

On October 13th, I have changed my domain from www.7tutorials.comwww.7tutorials.com to www.digitalcitizen.lifewww.digitalcitizen.life. I have made 301 redirects, kept the content, aliases, meta data, etc. The idea is that the new site is the old site with a new identity, new design and new features. The content is the same as on the old website.

However, I am experiencing a 70% hit in search traffic since October 18th. One of the areas where I'm not sure I've done things right is the SEO for pagination.

On 7tutorials.com7tutorials.com there was no pagination. On digitalcitizen.lifedigitalcitizen.life there is. Therefore, an article like this one: http://www.7tutorials.com/5-ways-boot-safe-mode-windows-8-windows-81, which had one page in total, is now redirected to http://www.digitalcitizen.life/5-ways-boot-safe-mode-windows-8-windows-81, which has two pages.

If you analyze the meta tags I used, you can see that I use link rel="next"link rel="next", link rel="prev"link rel="prev", and link rel="canonical"link rel="canonical". link rel="canonical"link rel="canonical" references the same URL but with the parameter ?nopaging=1?nopaging=1 at the end.

I am not sure I use them correctly though.

That's because I noticed that Google has indexed the URL mentioned in the link rel="canonical"link rel="canonical" field and it takes people to the version of the article without pagination. I do not want that. I want Google to take people to the first page of the article, which has the same URL as the on the old website, with the same page-rank flowing (hopefully).

Because of that I used Google Webmaster Tools and, in the section where you set URL Parameters, I set Google not to crawl pages with the ?nopaging=1?nopaging=1 parameter. See image below for details.

enter image description hereScreenshot of Google Search Console - URL parameters

However, Google seems to ignore my settings for now, even though they were made on October 14th.

Am I doing things right? What should I do in order to:

  1. Have Google send readers to the first page of each article, instead of the version with no pagination?
  2. Inherit the pagerank from the old articles to the "new" ones.
  3. Stop this 70% drop in search traffic and get close to the search traffic I was enjoying prior to this switch.

I'm pretty stressed out and I appreciate any ideas that you have.

Thank you! Ciprian

On October 13th, I have changed my domain from www.7tutorials.com to www.digitalcitizen.life. I have made 301 redirects, kept the content, aliases, meta data, etc. The idea is that the new site is the old site with a new identity, new design and new features. The content is the same as on the old website.

However, I am experiencing a 70% hit in search traffic since October 18th. One of the areas where I'm not sure I've done things right is the SEO for pagination.

On 7tutorials.com there was no pagination. On digitalcitizen.life there is. Therefore, an article like this one: http://www.7tutorials.com/5-ways-boot-safe-mode-windows-8-windows-81, which had one page in total, is now redirected to http://www.digitalcitizen.life/5-ways-boot-safe-mode-windows-8-windows-81, which has two pages.

If you analyze the meta tags I used, you can see that I use link rel="next", link rel="prev", and link rel="canonical". link rel="canonical" references the same URL but with the parameter ?nopaging=1 at the end.

I am not sure I use them correctly though.

That's because I noticed that Google has indexed the URL mentioned in the link rel="canonical" field and it takes people to the version of the article without pagination. I do not want that. I want Google to take people to the first page of the article, which has the same URL as the on the old website, with the same page-rank flowing (hopefully).

Because of that I used Google Webmaster Tools and, in the section where you set URL Parameters, I set Google not to crawl pages with the ?nopaging=1 parameter. See image below for details.

enter image description here

However, Google seems to ignore my settings for now, even though they were made on October 14th.

Am I doing things right? What should I do in order to:

  1. Have Google send readers to the first page of each article, instead of the version with no pagination?
  2. Inherit the pagerank from the old articles to the "new" ones.
  3. Stop this 70% drop in search traffic and get close to the search traffic I was enjoying prior to this switch.

I'm pretty stressed out and I appreciate any ideas that you have.

Thank you! Ciprian

On October 13th, I changed my domain from www.7tutorials.com to www.digitalcitizen.life. I made 301 redirects, kept the content, aliases, meta data, etc. The idea is that the new site is the old site with a new identity, new design and new features. The content is the same as on the old website.

However, I am experiencing a 70% hit in search traffic since October 18th. One of the areas where I'm not sure I've done things right is the SEO for pagination.

On 7tutorials.com there was no pagination. On digitalcitizen.life there is. Therefore, an article like this one: http://www.7tutorials.com/5-ways-boot-safe-mode-windows-8-windows-81, which had one page in total, is now redirected to http://www.digitalcitizen.life/5-ways-boot-safe-mode-windows-8-windows-81, which has two pages.

If you analyze the meta tags I used, you can see that I use link rel="next", link rel="prev", and link rel="canonical". link rel="canonical" references the same URL but with the parameter ?nopaging=1 at the end.

I am not sure I use them correctly though.

That's because I noticed that Google has indexed the URL mentioned in the link rel="canonical" field and it takes people to the version of the article without pagination. I do not want that. I want Google to take people to the first page of the article, which has the same URL as on the old website, with the same page-rank flowing (hopefully).

Because of that I used Google Webmaster Tools and, in the section where you set URL Parameters, I set Google not to crawl pages with the ?nopaging=1 parameter. See image below for details.

Screenshot of Google Search Console - URL parameters

However, Google seems to ignore my settings for now, even though they were made on October 14th.

Am I doing things right? What should I do in order to:

  1. Have Google send readers to the first page of each article, instead of the version with no pagination?
  2. Inherit the pagerank from the old articles to the "new" ones.
  3. Stop this 70% drop in search traffic and get close to the search traffic I was enjoying prior to this switch.

I'm pretty stressed out and I appreciate any ideas that you have.

1
source | link

Am I doing the SEO for pagination correctly?

On October 13th, I have changed my domain from www.7tutorials.com to www.digitalcitizen.life. I have made 301 redirects, kept the content, aliases, meta data, etc. The idea is that the new site is the old site with a new identity, new design and new features. The content is the same as on the old website.

However, I am experiencing a 70% hit in search traffic since October 18th. One of the areas where I'm not sure I've done things right is the SEO for pagination.

On 7tutorials.com there was no pagination. On digitalcitizen.life there is. Therefore, an article like this one: http://www.7tutorials.com/5-ways-boot-safe-mode-windows-8-windows-81, which had one page in total, is now redirected to http://www.digitalcitizen.life/5-ways-boot-safe-mode-windows-8-windows-81, which has two pages.

If you analyze the meta tags I used, you can see that I use link rel="next", link rel="prev", and link rel="canonical". link rel="canonical" references the same URL but with the parameter ?nopaging=1 at the end.

I am not sure I use them correctly though.

That's because I noticed that Google has indexed the URL mentioned in the link rel="canonical" field and it takes people to the version of the article without pagination. I do not want that. I want Google to take people to the first page of the article, which has the same URL as the on the old website, with the same page-rank flowing (hopefully).

Because of that I used Google Webmaster Tools and, in the section where you set URL Parameters, I set Google not to crawl pages with the ?nopaging=1 parameter. See image below for details.

enter image description here

However, Google seems to ignore my settings for now, even though they were made on October 14th.

Am I doing things right? What should I do in order to:

  1. Have Google send readers to the first page of each article, instead of the version with no pagination?
  2. Inherit the pagerank from the old articles to the "new" ones.
  3. Stop this 70% drop in search traffic and get close to the search traffic I was enjoying prior to this switch.

I'm pretty stressed out and I appreciate any ideas that you have.

Thank you! Ciprian