2 Added reference to Apache docs
source | link

You seem to have directory Indexes enabled (Apache automatically creates a directory listing in such cases). You can workaround this by either placing an empty index.html file in the document root of the subdomain (assuming index.html is a registered index document).

Or, disable directory Indexes in your .htaccess file (in the document root of your subdomain, or even in the document root of your main domain, depending on your file system structure.):

Options -Indexes

Reference: Apache Docs - Options Directive:

Indexes
If a URL which maps to a directory is requested and there is no DirectoryIndex (e.g., index.html) in that directory, then mod_autoindex will return a formatted listing of the directory.

You seem to have directory Indexes enabled (Apache automatically creates a directory listing in such cases). You can workaround this by either placing an empty index.html file in the document root of the subdomain (assuming index.html is a registered index document).

Or, disable directory Indexes in your .htaccess file (in the document root of your subdomain, or even in the document root of your main domain, depending on your file system structure.):

Options -Indexes

You seem to have directory Indexes enabled (Apache automatically creates a directory listing in such cases). You can workaround this by either placing an empty index.html file in the document root of the subdomain (assuming index.html is a registered index document).

Or, disable directory Indexes in your .htaccess file (in the document root of your subdomain, or even in the document root of your main domain, depending on your file system structure.):

Options -Indexes

Reference: Apache Docs - Options Directive:

Indexes
If a URL which maps to a directory is requested and there is no DirectoryIndex (e.g., index.html) in that directory, then mod_autoindex will return a formatted listing of the directory.

1
source | link

You seem to have directory Indexes enabled (Apache automatically creates a directory listing in such cases). You can workaround this by either placing an empty index.html file in the document root of the subdomain (assuming index.html is a registered index document).

Or, disable directory Indexes in your .htaccess file (in the document root of your subdomain, or even in the document root of your main domain, depending on your file system structure.):

Options -Indexes