Tag Info

Hot answers tagged

5

If wamp is running make sure no other program conflict Wamp such as IIS, Microsoft Web Deploy, SQL, Skype, Zonealarm, firewall/antivirus, NOD32, Eset, any web related program including Remote Desktop, Teamviewer ... IIS and Apache/Wamp are both web server and might conflict in some way, so you have to disable IIS in order for Wamp to work Disable IIS in ...


4

You first need a Facebook Developer Account that I'm sure you have already - You need to login and obtain an API Key by creating a new app. You can either use your own web host that has a SSL certification as this is now a requirement on Facebook or you can opt to publish your application using Facebook's Heroku Hosting. Most web hosting comes with SQL ...


3

For wamp 2.5 on Windows, use a text editor, e.g. notepad++ to edit c:\wamp\bin\apache\apache2.4.9\conf\httpd.conf Change DocumentRoot "c:/wamp/www" to DocumentRoot "c:/my/new/path" (Note slash direction). This will change the location where files are served from (~Line 230). Change <Directory "c:/wamp/www"> to <Directory "c:/my/new/path"> ...


3

Edit the httpd.conf file and/or the vhosts.conf file for the site wish to change. The Directory directive will let you specify where the files for this site are to be located. For more info on httpd.conf see: http://httpd.apache.org/docs/2.2/configuring.html And specifically: http://httpd.apache.org/docs/2.2/mod/core.html#directory


2

i had simalr problem and suggested answers didn't work for me. then read instructions of installing the application from -wampserver.com.... where it says: warning... you install install Visual C++ 2010 SP1 as shown below..... WARNING : You must install Visual C++ 2010 SP1 Redistributable Package x86 or x64 VC10 SP1 vcredist_x86.exe 32 bits : ...


2

I suspect a different approach will work better (I haven't actually tested this though:-). Try in your .htaccess something like ExpiresActive Off Header set Cache-Control "no-cache, proxy-revalidate, no-transform" Header set Pragma "no-cache" (No blank lines needed in .htaccess, but if I leave them out here "line wrap" thinks it's just a funky paragraph ...


2

I've just noticed @dan's comment above. If /test/ is indeed an Apache Alias, as set by WAMPServer, then the DirectorySlash may not be the problem after all. Both solutions are presented below. DirectorySlash directive You need to set DirectorySlash On in your Apache config (or .htaccess). This instructs mod_dir to implicitly append a slash in the case ...


2

I got it to work. First, I restarted the PC and then did the following: pressed Win + R (or go to start -> run) then write "services.msc" and open it find wampapache -> right click and start (or restart) find wampmysqld -> ight click and start (or restart) this forced the services to start, despite the fact that trying to start them from the wampserver ...


1

Your phpmyadmin configuration file contents in wamp alias folder must look as below: <Directory "c:/wamp/apps/phpmyadmin3.4.5/"> Options Indexes FollowSymLinks MultiViews AllowOverride all Order Deny,Allow Allow from all </Directory> Whereas it looks as this: <Directory ...


1

It could be a number of things but it is probably that apache is Listening on the W8 IPV6 default localhost address which is ::1 edit httpd.conf, using the link on the wampserver icon wampserver -> apache -> https.conf find the line > Listen 80 and change to > listen 0.0.0.0:80 This will force apache to listen on IPV4 and make the pre-configured ...


1

i just found why i was not getting it. click on wamp icon and go to phpmyadmin and click on database where u can see a database called mysql. So add database name as : mysql and username :root , password: leave as blank , admin and password : anything u wish. Maybe this is very simple .Posting it for starters who are stuck here.


1

You should really solve this by setting the DocumentRoot correctly on your local test server. Perhaps setup a VirtualHost for this test site, rather than changing your default server config if you are testing several sites? It is a local test server, so should reflect the settings of the live site as close as possible. However, it is possible (but not ...


1

Please reverse everything you have done thus far. Please uninstall IIS Server using Programs and Features, until you understand that IIS operates on port 80(default), and that Apache is also attempting to operate on port 80. You must either choose: To Configure IIS to operate on port 80, and set Apache to operate on port 8080. To Configure Apache on port ...


1

First, you "might" have a virus on your machine pretending to be an antivirus and using port 80. If your antivirus uses port 80 I think you should delete it immediately and install Windows Defender, for example. An antivirus should not use port 80! Second, WAMP might have automatically installed on another port since it might have found port 80 to be used ...


1

Try deleting the alias you just added. Add the alias back in manually, ideally by copying one you already have that you know works, then carefully modifying it accordingly. Be careful with spaces. As the accepted answer mentions, the new alias is almost certainly the problem. Only reason for adding a separate answer is that in my experience of this exact ...


1

When the WAMP icon turns orange it means that it wasn't able to start up properly. You say that you made a configuration change just before it turned orange. It sounds like you broke the Apache configuration when you added the alias. Although it is likely not to be the same exact problem you have here is a report from somebody who fixed the orange WAMP ...


1

After doing the above, you can also change the: in the of wamp directory (wampmanager.ini, wampmanager.conf). php.ini my.ini Save your changes and close Wampserver.


1

I found these simple steps helping, Click on WampServer icon in taskbar Select Apache > httpd.conf from the pullup Search for the term “DocumentRoot” Change the DocumentRoot path to your custom directory Search again for “DocumentRoot” again same procedure Save your changes and “Restart All Services”


1

Once you have migrated your files and database to Ubuntu, you can create a php file with phpinfo(); inside the file. View this in your browser and it will show you all the loaded php modules. For a list of loaded apache2 modules open a terminal and type apache2ctl -M To lookup your MySQL version there are a number of ways listed here ...


1

You will experience a difference in performance anyway, regardless of what environment you use. I used to use WampServer and I would find this quite slow sometimes, similar to what you have explained. I then started using XAMPP and have found it to run much better, although sites on my XAMPP installation are still noticeably slower. Recently though I have ...


1

I am seriously considering a VirtualBox environment on my Windows machine to run a flavour of Linux and a LAMP stack with my Drupal site(s) on. Hopefully this doesn't have the same bottle necks as the WAMP stack.


1

Add that domain in hosts: C:\Windows\system32\drivers\etc 127.0.0.1 domainname.com


1

Actually I think it is something different. When I tried to load a site with ExpiresActive On in the .htaccess file my site also does not load. In the apache error.log it says the following: Invalid command 'ExpiresActive', perhaps misspelled or defined by a module not included in the server configuration After enabling Expires Module through WAMP system ...



Only top voted, non community-wiki answers of a minimum length are eligible