Tag Info

Hot answers tagged

8

When you type the URL in a web browser, http://www.foo.com, it will always attempt to connect on port 80. It's not so much that the port is being hidden, but rather that it's being assumed, since port 80 is the default for HTTP requests. Along the same line, if you browse to https://www.foo.com, it will always attempt to connect on port 443 unless you ...


5

You might want to check out SliceHost or Linode. Neither though offers plans around what you are looking at ($10/mth). But then again I wouldn't pay less than $20/mth for a decent VPS. Less than that and you probably aren't getting the best service. Both have great tools available on their control panels, good customer service, good uptime and reasonable ...


4

http://www.flowerwood.com is pointing to 69.85.232.203 http://plants.flowerwood.com is pointing to 98.124.199.1 Change the DNS record for the plants dubdomain to point to the same IP as flowerwood.com. (This post assumes default behavior of a cPanel/Apache setup. Also assuming that the subdomain is also on the same server. All pretty vanilla assumptions ...


4

FIRST: First defined VirtualHost will be used as catch all for unknown domain names. Apache does not know about apples.co.uk -- it only knows about www.apples.co.uk. So it uses first Virtual Host to serve apples.co.uk. Redirect will work OK here. Apache does not know about bananas.co.uk -- it only knows about www.bananas.co.uk. So it uses first Virtual ...


4

You must put AllowOverride All in your <Directory/> section of the server configuration. The only Apache configuration files that can allow options are the ones directly in the server (main file, virtualhost, etc.). The .htaccess file can only remove override rights. That is: <VirtualHost *:80> DocumentRoot "C:/xampp/htdocs/ypp" ...


3

Apache configuration is exhaustively covered in the Apache documentation (though, if you're using Debian or Ubuntu, there are some additional considerations) and the best way to familiarize with Apache will be to study each portion of the documentation as you encounter a need to use a particular module or set of directives. To address your specific ...


3

You need to make a separate VirtualHost for each port, like so: #assuming you have this in your config NameVirtualHost *:8000 NameVirtualHost *:8001 NameVirtualHost *:8002 NameVirtualHost *:8003 # (...) Listen 8000 Listen 8001 Listen 8002 Listen 8003 # (...) Then each VirtualHost looks like this: <VirtualHost *:8000> ServerName localhost ...


3

It is most likely causing an infinite loop as they are the same. The default pages in Apache are index.html and index.htm. If the browser does not request a file name the web server will return one of those files if it finds them. So When you go to http://domain-name.com you are actually viewing http://domain-name.com/index.html just without /index.html


2

I faced a similar issue using mod_rewrite and mod_proxy. http://serverfault.com/questions/296159/need-to-redirect-to-static-url-based-off-of-string-patter-match-in-uri The problem is that you are bypassing .htaccess file with your proxy rule. Meaning if you place your file in your web root it will not be seen since you are proxying / to rootTomcat and not ...


2

Maybe your config has wrong IP? 127.0.0.7 test.local This one should work just fine: 127.0.0.1 test.local Additionally you may have incorrect <VirtualHost> directives formatting (unless this is happened when you inserted text here). Instead of Options Indexes FollowSymLinks Includes AllowOverride All should be Options Indexes FollowSymLinks ...


2

You need to either specify a single host here, or ask whoever you're thinking about directly. This isn't done the same way by all hosts, but as far as a couple of the later points, some disclose details within their technical information for how this is calculated. Others actually provide a view of the data within their control panels. If they don't, ...


2

If you have multiple users with different websites on your server, it's commonplace to place the user's website in a directory within their home folder and use the Apache configuration to point the relevant domain name at the appropriate directory. /home/somesiteuser/public_html /home/anothersiteuser/public_html ...etc... The has the added benefit of ...


2

Just create another virtual host for mail.example.com, and you can tell Apache to do whatever you want when people go to that host. <VirtualHost *:80> ServerAdmin admin@example.com ServerName mail.example.com ErrorLog logs/example_com-error_log # if you care about hits: CustomLog logs/example_com-access_log common Then, if you ...


2

The HTTP protocol uses port 80 by default. If you configure your web server to use a nonstandard port, then the port needs to be specified in the URL. There's no way to hide that. In Apache, you can set the listening port in httpd.conf, e.g.: Listen 127.0.0.1:80 This can however be overridden in the vhost config, e.g.: <VirtualHost *:80>


2

There are two places that you can write (you can use both of them): ServerName: is the "internal" name of the vhost. It is not necessary the full qualified domain name. Just "myvhost" could be ok. Of course you can use the full name like "myvhost.example.com". ServerAlias: is other names. It is useful when you want multiple domain names for the same vhost. ...


2

First; add port to your ServerName < VirtualHost *:80 > DocumentRoot C:/server/htdocs ServerName localhost:80 < /VirtualHost > Second Chance, give a different name to ServerName and add the ServerName to the windows hosts file, this is located in “C:\windows\system32\drivers\etc\hosts”. Open the file in Notepad and simply add; ...


2

Given the configuration you describe I'm sort of surprised that you apache is starting. Try configuring your hosts file like this 127.0.0.1 localhost myawesomeproject.com then tidy up your vhosts like this <VirtualHost *:80> DocumentRoot "C:\xampp\htdocs" ServerName localhost </VirtualHost> <VirtualHost *:80> ServerAdmin ...


2

Stick with the same port. Port numbers are only used to initiate a connection, then they are moved to a pseudo-random port that's really high and likely not in use. The data transfer does not happen on port 80 for example. (To test this, run iptraf on your server and then download a large file from another computer. You'll notice that it's probably in the ...


2

Just do it the other way round, instead of redirecting to the domain example.com, tell the server which page to display when a user requests the domain directly. In the .htaccess file you can write (this is the default anyway): DirectoryIndex index.html Now if somebody requests http://example.com the server will actually send back the index.html file, ...


2

The default host that is the one that is first # Default host (must be first) <virtualhost *:80> # I use localhost.localdomain, but any host name not matching later hosts gets handled here Servername localhost.localdomain DocumentRoot /home/www/default_site ... </virtualhost> <virtualhost *:80> ServerName ...


2

You can use nginx as a load balancer and configurate it to correctly handle the server certificates just as normally would happen. All the configurations are explained in http://www.cyberciti.biz/faq/howto-linux-unix-setup-nginx-ssl-proxy/ Instead of using the self-signed certificates, a purchased one can be used.


1

This may be all there is to it, but at the VERY beginning of that config file, put this line: Listen 80 This tells Apache to actually listen for requests on port 80, and should help it work with the NameVirtualHost directive. ALSO!!! You have a typo on line 33: <Directory "D:/wwwroot/b/public"s> Should the problem persist, post your entire ...


1

Apache Httpd, like most servers, doesn't support using the same port for two different protocols (HTTP and SSL/TLS here). Doing so would require the server to be able to detect the protocol based on the content of the initial request: whether it's looks like an HTTP request or if it's an SSL/TLS Client Hello message. Some servers can do this (e.g. Grizzly ...


1

Actually, it is impossible to specify different php.ini files for each virtual host. However you can change almost anything in the php.ini file by using the ini_set() function: It allows you to set the value of a given configuration option. The configuration option will keep this new value during the script's execution, and will be restored at the ...


1

As you correctly note, the web hosting provider wants to have control over the actual IP address your host name resolves to, so that they can e.g. move your site from one server to another or implement DNS-based load balancing. There are basically two ways in which this can be done. For example, assuming that the hostname you want for your site is ...


1

I came up with a reasonable solution to this problem. Instead of mixing core js-host configuration with lots of reverse proxy configuration, I separated the two. js-host is now a standalone site that knows nothing about the other services. The key to this approach is to add a reverse proxy for '/' to the core js-host site below all the other reverse proxy ...


1

I had that same issue, and don't know why it is failing either. I was able to work around it using this instead: <VirtualHost *:80> ServerName domain.com ServerAlias *.domain.com # Redirect 301 / https://www.domain.com RedirectMatch permanent /(.*) https://www.domain.com/$1 </VirtualHost>


1

Change to this and try it, notice only two VirtualHost <VirtualHost *:80> ServerName domain.com ServerAlias *.domain.com Redirect permanent / https://www.domain.com/ </VirtualHost> <VirtualHost *:443> DocumentRoot /var/www/domain/ ServerName www.domain.com SSLEngine on SSLCertificateFile ssl.crt SSLCertificateKeyFile ...


1

I don't have any experience with Mono, but it seems like the other sites should work if you leave the location as / but only the base site would work if you set the location as /Landing. What most people would do is simply leave the location as / and use mod_rewrite to map non-phpmyadmin or -phpvirtualbox requests to the /Landing/ directory, e.g. ...


1

It is not that hard but you will have to get your hands dirty :) It sounds like your Apache is currently only running the one site, which makes things a little easier. Get Apache to start. In general, you enable as a service and it starts every time your computer starts. The exact command to do this depends on your operating system but most modern ones ...



Only top voted, non community-wiki answers of a minimum length are eligible