Tag Info

Hot answers tagged

11

This is an XY problem. You want to prevent indexing on your site and you know that 404s are not indexed, so you want to prevent indexing 'using' 404s. This is the wrong way to go. There are many proper ways to prevent indexing such as using robots.txt, meta tags or authentication.


9

If this is a test site that shouldn't be indexed at all, there are a couple of steps you can take that tell search engines not to index your site more effectively than returning 404 headers. robots.txt Include a robots.txt at the site's root including: User-agent: * Disallow: / X-Robots-Tag Include the following to your .htaccess to add an X-Robots-Tag ...


3

Hey guys I finally figured it out, some how the code that works to do this in Modx CMS is below! This code shows you how to install it in a folder on your server. It tells the htaccess file to read the .html extension and loads up the page without a problem. #works, so happy!! # MODX supports Friendly URLs via this .htaccess file. You must serve web # ...


2

Use a TV with the @DOCUMENT binding or the getField-Snippet. Both methods work for MODx Evolution. On MODx-questions, please include whether your are using Evolution or Revolution, since the code base differs heavily, as so does the functionality.


2

Possibilities ModX EVO CMS is deleting it Malware/Virus is deleting it Shared Hosting is causing it, i.e malware/virus on another user account spreading to yours. Web host is deleting it for one reason or another. How to Investigate Contact your web host if shared hosting Check logs Quick Fix I'm assuming that you are using CHMOD 744 or 777, there ...


2

# Make sure RewriteBase points to the directory where you installed MODX. # E.g., "/modx" if your installation is in a "modx" subdirectory. RewriteBase / As stated in the comments at the top of the file, RewriteBase should be set to your subdirectory: RewriteBase /makeabio This affects the relative path substitution later in the file (half way down): ...


1

It does sound like a base href problem, like Aaron suggests. However I would never advise anyone to hardcode it to <base href="http://domain.tld"> - this is a pain if you ever want to copy a site to a staging environment or migrate the site elsewhere. Instead the simple solution is to have the base href value resolve dynamically and ensure it is ...


1

Are you using dynamic base href property in your MODx templates? If so set this to the actual website address you want to be the base href, then clear the MODx cache and you should be all set.


1

Identify How The File Got Changed First off you want to address the problem of how they are getting into your system since a chmod 755 means only the owner (The web server, ie Apache/iis) has access to write to the files therefor something else is doing the written to these files via your CMS/SQL/PHP. Identify how they got in... (Check access.logs, ...


1

What you need to do is request a Malware Review which is not the same as a usual reconsideration request as it is handled by an entire different team. You do this from the Webmaster Tools. Google explains all the steps in the process here. If all you are missing is the Review, see here.


1

A 550 FTP error means you don't have permission to perform a particular operation (write to a directory, modify a file, delete a file, change the permissions on a file, etc.). It has nothing to do with whether your files reside directly in the webroot of a domain or if it's under a subdirectory.


1

use a different resource group for the Travel and Articles resources. UPDATE You might have to create a new policy for these users, OR probably the easiest thing to do is to customize the manager form and hide/disable the fields you don't want edited from the groups/users you don't want to have access to. [admin->security->form customization]



Only top voted, non community-wiki answers of a minimum length are eligible