Tag Info

New answers tagged

1

Your issue is duplicate content. Specifically, there is another page on the internet with substantially the same biography: http://csteps.illinois.edu/dr-emma-mercier/ When Google sees the same biography on two different pages, it will choose only one of them to index.


2

I originally read you question as the number of indexed pages from your sitemap is 1500 and that you are worried. Then I thought about it. Perhaps there are things you need to know. If your site is new, then it will take quite a while for a new site to be indexed. I am not sure how old your site is, but it can take as much as a year for some sites to sink ...


1

Try to make text more english, especially the text in the title tag, and in Webmaster tools, select the website domain, then the gear icon, then "site settings" then for crawl rate select "Limit Google's maximum crawl rate" and select the right-most point on the slider that appears so that Google can scan your site faster. Just make sure you don't have ...


2

The problem you have is with your responsive design, and more specific - your breaking points. You can easily see that your website actually look exactly like the screenshot on 1024px width (see http://responsivetest.net/#u=http://www.wetravel.co.il/|1024|768|1) or just minimize your browser's width, you'll see the breaking point eventually). Google test the ...


1

Hi this is due to a 3rd party site linking to your domain to a page on your site that doesn't exist. So Google has followed a link from another website to yours - but because the link is incorrect at the other website when Google hits your site it gets a 404 error because the page that's being linked to doesn't exist. This isn't your fault as is usually due ...


0

Method 1: Check your robots.txt and sitemap.xml file. Maybe you disallowed Google to crawl the folder or file. Method 2: Try to rename your image. It can take some hours or days. Find more infos under https://support.google.com/webmasters/answer/182072.


1

Robots.txt does not block search engines from indexing a link, only the content of that link. So what is likely happening is that Googlebot is visiting your page even though it knows it can't index the contents of that page, only the url. From Google Webmasters: Blocking Google from crawling a page is likely to decrease that page's ranking or cause it ...


1

The google structured data policy describes a few exceptions such as including machine readable data to avoid ambiguity (dates, prices, etc). What is actually says it that the extra meta tags of hidden information are not displayed which suggests they may still be useful in search results although the extra data won't preview. The better solution would be ...


3

This is because... User-agent: * Sitemap: https://m.mysite.com.au/sitemap.xml ...would be incorrect. The correct syntax for the robots.txt is: To disallow all: User-agent: * Disallow: / To allow all: User-agent: * Disallow: To disallow specific directories: User-agent: * Disallow: /cgi-bin/ Disallow: /tmp/ Disallow: /junk/ Examples taken from ...


0

Unfortunately, it looks like you can't control this at present. I will send this feedback to the Search Console team - it might be a point to update as they roll out the new Search Analytics reports.


1

Going by your example, I will guess that google chooses the word "contact" over "hi let's talk" as a title because your page probably has the word "contact" more than once and it sounds more professional. But if you want a good chance at having your title as the title in search results, then you want to make it related to your page. This means having ...


2

I am not sure about how Google might treat an Italian site, however, I rather suspect the process is the same. So I will continue. In your case, Google likely does not like the title as provided in the title tag. It is important that the title tag is not too short or too long and that the title tag be carefully crafted especially when using the pipe ...


1

In your last example, I'm not sure this will create a benefit in your sitemap: <xhtml:link rel="alternate" hreflang="x-default" href="https://www.domain.com/what-we-do" /> This is because I don't think "x-default" is a standard language. And besides, you provided the default URL here: <loc>https://www.domain.com/what-we-do</loc> It ...


4

You're better off creating a multilingual sitemap, just to avoid any source of confusion. The format you have shown is correct. In fact, you could even drop the hreflang declarations in your page sections and just use the declaration within the sitemap. The Official Webmaster Tools blog explains the advantages of using the multilingual sitemaps ...


0

Search engine updates aren't instantaneous. In fact it can take a couple of weeks or so to be visible.


0

Yes this is normal for a site of your size. Google throttles the indexing of pages to prevent the manipulation of their search results. As your site becomes more seasoned (domain age, external links, spider visits. etc) more of your pages will show in their index. If you are properly using the sitemap and internally linking your pages together via site wide, ...


0

Google likes to cache pages in search results to give users the option to view the cached page in case the real site goes down. What you can do in every page that you updated that Google still reports incorrectly is add the following HTML code between <head> and </head> of your outputted HTML code that the web browser processes: <meta ...


0

Turns out we had a Pure Spam manual action on our domain. I'm assuming this was due to a previous owner's shady activities since the domain was first registered in 2011. I've submitted a detailed request for review.


4

In your root .htaccess, using mod_alias: Redirect 301 /home / However, if you are already using mod_rewrite (very likely that you are if this is still a Joomla site) then you should use mod_rewrite: RewriteEngine On RewriteRule ^home/(.*) /$1 [R=301,L] Nothing else to do in Google Search Console (formerly known as "Google Webmaster Tools").


4

This is just an ad. Google apparently does not check to see if you already have a Google Webmasters Tools account before displaying the ad. I see this all the time for my site. Nothing to worry about.


1

Whereas the answer by Andrew makes sense and is in line with the official response by Google, I see 3 types of errors in my website: A URL containing an URL-encoded URL is linked back using the properly encoded URL. E.g. http://example.com%3Flang%3Dzh is linked back as http://example.com?lang=zh - there is not much I can do if someone is linking my site ...


1

well, turns out that google webmaster tools as well as many other applications doesn't correctly handly FQDN, and just apply a redirect (some browsers) or just ignore it and work with the ambiguous domain name directly (some apps). to force them to work: RewriteCond %{HTTP_USER_AGENT} ^.*Googlebot.*$ RewriteCond %{HTTP_HOST} !^example\.com$ [NC] ...



Top 50 recent answers are included