Sign up ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

so I've set to point to, which correctly loads my Google site, but if you go to, it doesn't redirect/forward to, it just hangs. is there a way to change this in the Godaddy DNS manager?

share|improve this question

migrated from Mar 1 '11 at 15:25

This question came from our site for professional and enthusiast programmers.

I had a goDaddy account and their support is actually nice. Give them a call and they'll help you. Other than that I don't think this is the place for such a question. – PedroC88 Mar 1 '11 at 15:24

2 Answers 2

up vote 17 down vote accepted

It's not a DNS setting; you need to set up a redirect from to Fortunately, Godaddy provides this service for free; follow the directions at

share|improve this answer
perfect thanks, that was it – chrismarx Mar 1 '11 at 15:48
Does this forward to or does it ignore the rest of the URL? – bimorphic Mar 23 '11 at 9:12
@CodingTales: yes, it will redirect all requests to the same URL with just the hostname replaced. – Wooble Mar 23 '11 at 12:46

Its not subdomain at all. I am using domain forwarding. Just select forward of domain, not subdomain, and add www to it, and forward only, and it automatically adds the ip address in the A record of DNS in godaddy. If you are using cloudflare, do it in the dns settings on godaddy first and then add domain to cloudflare or if you are already using cloudflare, the delete domain off of cloudflare, and redo the dns and forwarding on godaddy, then rescan on cloudflare, if the dns settings do not show up from godaddy, then add them from godaddy by copying and pasting the settings over to cloudflare, and then add cloudflare nameservers over to godaddy.

If you arent using cloudflare, then just forward the domain non www to the forwarding of www under domain forwarding in godaddy as said at first, then wait and it will do it. I put an extra A record with * pointing to the forwarding ip address too, so you have two A records, one with * and other with @ pointing to ip address.

share|improve this answer

protected by Community Jul 6 at 16:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.