Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a simple setup.

  1. Server at home has local I.P. 192.168.1.3
  2. IIS is running on the server and the website is up.
  3. Windows firewall on the server has an exception rule for port 80 TCP
  4. Router has static I.P. XX.XXX.XX.XXX
  5. Router is forwarding TCP port 80 to 192.168.1.3
  6. My domain registrar is my DNS host and is pointing to the static I.P. XX.XXX.XX.XXX of the router

Here's what I can and can't do.

  1. I can browse the website from within my home network either by I.P. or domain name.
  2. I can ping the domain and the I.P. from outside the network (from a computer at work).
  3. I can't browse the website either by domain name or by I.P.

Weird. Why I can't browse my website?

Incidentally, I wasn't sure this question was appropriate for SO, but after finding a few others similar to it on SO, and no comments on those questions saying anything about it being inappropriate, I decided I would post this question. Let me know if this is not appropriate for SO, or is more appropriate for another of the SE websites. Thanks!

share|improve this question

migrated from stackoverflow.com Feb 2 '11 at 11:53

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 1 down vote accepted

The router's firewall and other protection software was enabled. Comcast forgot to disable this when they gave me a static I.P.

When they disabled it and put it in to "pass-through" mode, voila, website is browseable.

share|improve this answer
    
you should "accept" an answer so that everyone will know that the problem is solved and won't keep coming to this page –  Stephen Feb 1 '11 at 20:57
    
@Stephen, I will, but unfortunately I can't accept my own answer for another 2 days. SO rules. –  Richard DesLonde Feb 1 '11 at 21:00

Your ISP is likely blocking port 80. Try setting/forward on some other port and see if it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.