Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

My main domain works just fine - www.example.com and a subdomain set up by another developer works as well - sub1.example.com. But when I try to set another subdomain up I go through the process everything seems to work. The software creates the default files where the subdomain files should go. But when I try to browse there it doesn't work. My host uses Plesk to do all of the hosting stuff.

What do you think the problem is?

I doubt it is some sort of cache issue because I had problems on my phone which I tried after problems on the pc. Maybe for some reason Plesk needs time to set this up? I have used Cpanel before and that works instantly.

EDITED Additional Information provided by the OP

When I ping the domain I receive this reply:

ping: cannot resolve drnick.burnhamrichards.com: Unknown host

Viewing the url in my broswer gives this error:

Oops! Google Chrome could not find sub1.example.com

I visited the IP and I got a generic landing page that says something like "welcome, you see this page because there is no website at this address" and since I am using virtual hosts I imagine that is what I am supposed to see.

When I log into plesk I see that the a-records for both sub1.example.com and sub2.example.com are pointing to the same IP.

share|improve this question

migrated from serverfault.com Jan 5 '11 at 8:17

This question came from our site for professional system and network administrators.

Perhaps the world's DNS servers don't know of it yet? –  TheLQ Jan 4 '11 at 22:40
Try using a host entry on your computer to map the IP to the domain name. This would tell you if the server itself is configured properly to help determine if you're simply waiting for the DNS to propogate. –  jmort253 Jan 5 '11 at 2:20
@TheLQ: If they didn't know, they would query and get it. (new subdomains work instantly). DNS problem can come only if they subdomain has been mapped to an older IP. –  JP19 Jan 5 '11 at 9:18
@ BFTrick: What does ping yoursubdomain.example.com show you? –  JP19 Jan 5 '11 at 9:18

3 Answers 3

To fix your problem, you simply need to go into your sub domain settings within your control panel and switch on the DNS Service for the sub domain. This is often missed after creating a sub domains.

share|improve this answer

use something like http://www.dnsstuff.com/ or http://dnstools.com/ to make sure all the records are set up correctly.


share|improve this answer

What do you think the problem is?

No idea, you provided almost no useful information.

But when I try to browse there it doesn't work

Please define doesn't work.

For example do you get an error about the Domain not existing? Perhaps try using nslookup or some tool to verify that the DNS records for the domain was created properly. What happens if you try to ping our traceroute to the new domain?

Do you get a connection time out? Perhaps there is some kind of routing or firewall issue. Maybe the wrong IP address got associated with the DNS record.

Can you visit the IP that you have associated with the new domain? If you using name-based virtual hosts, you may not get to the web site, but if you get a connection refused, or a timeout, then you may be using the wrong IP.

You made an update to DNS, do you know if it adjusted the SOA record?

Have you tried flushing the DNS cache on your local machine?

Please take some time to clearly describe precisely what the symptoms are and what you have tried to test.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.