Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

After installing postfix, there seems to be a problem when I try to send a mail through wordpress. After looking at the logs, this is what I found.

Aug 27 12:00:01 tehnika postfix/cleanup[2797]: warning: database /etc/postfix/virtual.db is older than source file /etc/postfix/virtual
Aug 27 12:00:01 tehnika postfix/pickup[2686]: 5E9BA81BF4: uid=109 from=<smmsp>
Aug 27 12:00:01 tehnika postfix/trivial-rewrite[2798]: warning: database /etc/postfix/virtual.db is older than source file /etc/postfix/virtual
Aug 27 12:00:01 tehnika postfix/cleanup[2797]: 5E9BA81BF4: message-id=<20140827160001.5E9BA81BF4@tehnika.mk>
Aug 27 12:00:01 tehnika postfix/qmgr[1994]: 5E9BA81BF4: from=<smmsp@mail.tehnika.mk>, size=682, nrcpt=1 (queue active)
Aug 27 12:00:02 tehnika postfix/smtp[2799]: 5E9BA81BF4: to=<root@mail.tehnika.mk>, orig_to=<root>, relay=none, delay=0.74, delays=0.01/0/0.72/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.tehnika.mk type=AAAA: Host not found)
Aug 27 12:00:02 tehnika postfix/cleanup[2797]: 1E3D481BF5: message-id=<20140827160002.1E3D481BF5@tehnika.mk>
Aug 27 12:00:02 tehnika postfix/qmgr[1994]: 1E3D481BF5: from=<>, size=2582, nrcpt=1 (queue active)
Aug 27 12:00:02 tehnika postfix/bounce[2800]: 5E9BA81BF4: sender non-delivery notification: 1E3D481BF5
Aug 27 12:00:02 tehnika postfix/qmgr[1994]: 5E9BA81BF4: removed
Aug 27 12:00:02 tehnika postfix/smtp[2799]: 1E3D481BF5: to=<smmsp@mail.tehnika.mk>, relay=none, delay=0.33, delays=0/0/0.33/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=mail.tehnika.mk type=AAAA: Host not found)
Aug 27 12:00:02 tehnika postfix/qmgr[1994]: 1E3D481BF5: removed
share|improve this question

closed as off-topic by John Conde Aug 27 at 17:17

  • This question does not appear to be about webmastering within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Questions on professional server, networking, or related infrastructure administration are off-topic for Pro Webmasters unless they directly involve programming or programming tools. You may be able to get help on Server Fault. As your question is currently written it probably would not meet that site's quality guidelines. I recommend reading their FAQ to ensure your question is appropriate for their site. –  John Conde Aug 27 at 17:17

1 Answer 1

up vote 0 down vote accepted

I am not sure how mail.tehnika.mk is getting picked up. mail.tehnika.mk is not a valid sub-domain/domain. I did a quick look-up for MX records for tehnika.mk and found mx.zohomail.COM and mx2.zohomail.COM which are not your domain.

It appears that your Wordpress is sending the e-mail to postfix, but the smmsp@mail.tehnika.mk e-mail address is incorrect.

If you intend that smmsp@mail.tehnika.mk should be smmsp@tehnika.mk then you need to check your configuration(s) to make sure that the e-mail address used is correct. Not knowing Wordpress, I would start there and change smmsp@mail.tehnika.mk to smmsp@tehnika.mk. Otherwise, I would be checking your Linux user and making sure that the e-mail address is smmsp@tehnika.mk.

If you intend that smmsp@mail.tehnika.mk should be correct, then you need to create an MX record for mail.tehnika.mk by first creating a CNAME that points mail.tehnika.mk to tehnika.mk. Then you would need to create an MX record for mail.tehnika.mk. Then remove the other MX records found above.

The problem you have is that the existing MX records are not pointing to your domain. These have to be removed and an MX record created that points to your server. You have two options, mail.tehnika.mk or tehnika.mk. If you intend that smmsp@mail.tehnika.mk should be correct, then follow the steps above. Otherwise, check the user e-mail addresses in your configuration(s) and create an MX record as prescribed for tehnika.mk.

share|improve this answer
    
The MX records found mx.zohomail.com are used so I can send recieve mail with the Zoho service. This is similar to gapps, or outlook custom domains. What I'm trying to do is set-up postfix so a simple contact form plugin for wordpress can send e-mails through SMTP, or have a plugin notify my by e-mail such as a firewall. –  Petar Petkovski Aug 27 at 16:55
    
@PetarPetkovski Okay. I understand. Change the user e-mail address or create a CNAME for mail.tehnika.mk without a new MX record or deleting any MX records. This will retain your setup for incoming e-mails. But as it stands, the e-mail address smmsp@mail.tehnika.mk is invalid and will not pass muster. –  closetnoc Aug 27 at 17:00
    
smmsp is is a dummy user set up to run sendmail. he's part of the sendmail package. it's a security measure to allow strict file permissions,and a second line of defense against the risk of sendmail security being cracked. I haven't created that :) –  Petar Petkovski Aug 27 at 17:02
    
@PetarPetkovski The smmsp user name is not the issue. What is invalid is your sub-domain name which does not exist. In order for the user name smmsp to work, change the e-mail address to smmsp@tehnika.mk and your problem should go away. This is the simplest and fastest solution. –  closetnoc Aug 27 at 20:18
    
There were several steps involved to fix the problems. First I ran the "dpkg reconfigure postfix" command and from there I've changed the domain to "tehnika.mk". Then in the /etc/postfix/main.cf configuration file, I've removed the entry "tehnika.mk" from "mydestination" and left the field empty. Now postfix looked up MX records, and delivered the mail straight to Zoho servers, instead of delivering it in /var/mail/username. Aug 27 16:41:42 tehnika postfix/smtp[7325]: to=<mail@tehnika.mk>, relay=mx.zohomail.com[74.201.154.201]:25, status=sent (250 Message received) –  Petar Petkovski Aug 27 at 20:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.