Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have 2 accounts with websites on my VPS - one had an old website, the other I was developing a new website on.

When I had finished the new website I simply went to 'Modify Accounts' and swapped the Domain Names fields of both accounts, so that the new account had the old accounts domain name and vice versa.

Now neither site works - I just get the standard CPanel defaultwebpage.cgi place holder.

Have I missed something? Does anyone know what I can do to fix this?

share|improve this question
    
I wish I had an answer for you! Someone will. Can your host tech support help you? –  closetnoc Jul 29 at 4:52
    
Does this page help? –  eyoung100 Jul 29 at 13:42

1 Answer 1

What do you mean you have 2 accounts with websites no my VPS? Do you mean on your VPS you have two domains hosted, through two cPanel accounts created in WHM?

I would first backup all files and databases. Then go in with SSH and look to see what folders the files are in and review apache's global and site configuration files to see what happened when you made the switch in WHM.

You can use easy apache to rebuild the configuration file. Then recreate the accounts individually and upload the files and import databases for each domain.

In the future when you work on a development server (domain) which you want to migrate to the products / live server instead of messing with WHM settings just overwrite the live files after you've made backups.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.