Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have my site hosted at http://blog.rgksugan.in. I have set a subdomain in it for my blog. But after landing on my blog whatever other links I click i get the link as http://rgksugan.in/blog/wordpress/stack-overflow/.

I want it to be http://blog.rgksugan.in/stack-overflow

What should I do...?

share|improve this question
1  
You should ask it here: wordpress.stackexchange.com I don't remember coz' I hate wasting time doing insatallation chores with WP. Anyway I'm quite sure your subdomin document folder is rgksugan.in/blog so it's simply WP creating wrong links. It should be easy to fix it's probably just a matter of setting something in WP configuration. –  Marco Demaio Dec 2 '10 at 19:07
    
Did aendrew answer your question rgksugan? –  Christopher Feb 14 '11 at 19:22
add comment

1 Answer

up vote 1 down vote accepted

You generally can do this in wp-admin by going to Settings -> General and setting "WordPress Address (URL)" and "Site Address (URL)" to include the subdomain. That said, please read this before do that: http://codex.wordpress.org/Moving_WordPress

Be forewarned this may break content and it seems going to blog.rgksugan.in just redirects to the main site without forwarding any of the requests: http://blog.rgksugan.in/blog/2011/01/27/capture-network-packets-java/ and http://blog.rgksugan.in/2011/01/27/capture-network-packets-java/ both redirect to your front page. This makes me think WP isn't actually installed at blog.rgksugan.in and that the subdomain is just a forwarding DNS record.

Basically, make sure the site is actually hosted at blog.rgjsugan.in before trying to change anything in WP Settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.