Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

When I make a search on Google and find my website; then I see the URL (the green line below the page title) is saying www.domain.dk/?lang=nb.

I found out that nb is short for Norwegian. How do I remove the ?lang=nb or at least change it to ?lang=da since my website is in Danish? I have already written this inside the head-tag:

<meta name="language" content="da" />
share|improve this question
1  
If you click through to that URL, do you see that parameter on the URL of your site as well? –  Stephen Ostermiller May 5 at 11:54
    
@StephenOstermiller Yes, the URL will then have the ending "?lang=nb". To be honest I would like it without the ending! –  amadeo May 5 at 11:57
2  
I think the real question is why Google is showing your URLs with ?lang=nb if you are not using this URL parameter on your site. (Presumably this URL param is not used by your site?!) This isn't suggesting that "Google says my website is Norwegian", this is simply suggesting that Google has found links to your site that contains ?lang=nb (?) –  w3d May 5 at 12:24
    
The URL parameter has nothing to do with how Google sees the language of the content -- it's purely how that page is indexed. So don't focus on the language, focus on the URL here. –  John Mueller May 7 at 6:14

2 Answers 2

I recently read this documentation, Google doesn't look at the language tags, but at the language of the contents.

For instance, doing content="da" with an english content will make it an english site. Somehow Google confuses your Danish with Norwegian.

Same goes for the URL, it doesnt check the URL.

From the documentation:

Google uses only the visible content of your page to determine its language. We don’t use any code-level language information such as lang attributes

share|improve this answer
    
So you're saying I should just wait until google realizes that the content is Danish? –  amadeo May 5 at 12:22
    
Yup. And maybe figure out where the lang=nb comes from, and doublecheck all your language headers (eg in html, php) –  Martijn May 5 at 12:26

For Google to be showing to your page with that parameter, something must be linking to it like that.

You might be able to figure out where that link is from using Google Webmaster Tools. Sign into your site and navigate to "Search Traffic" -> "Links to your site". From there, look in "Your most linked content" and try to find that URL. Click on it to find out where the links are coming from.

If you use Google Analytics, you might also be able to find it there. Navigate to "Behavior" -> "Site Pages" -> "All Content". Find that URL and click on it. Choose a secondary dimension of "Referral path" to see what is linking to it like that.

I suspect that you will find that you are linking to your home page like that from somewhere on your own site. If that is the case, fixing the link on your own site would be the easiest course of action.

You can also fix the problem using "URL Canonicalization". You can either use 301 redirects to remove parameters, or put meta canonical tags on your pages letting Google know what your preferred URLs are. Here is a guide to doing so. You don't say what software powers your blog, but there are plugins for canonical URLs for most blogging platforms. For example Yoast is a WordPress plugin that does it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.