Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Sorry for the duplicate question but I'm a newbie and see that I posted wrong the first time. Parked a domain from my previous company website on top of my existing company website. The URL from the other site is now showing for some of my top keywords in the SERPS but with my meta info and linking to my page. How do I fix this?

share|improve this question
add comment

1 Answer 1

Do a 301 redirect from the parked domain to the new domain. That will tell the search engines that the existing domain is the main one and will eliminate potential duplicate content issues. It will also be less confusing for your users as they will see a consistent domain when accessing your site.

If you are using Apache you can do this easily with a snippet in an .htaccess file in your root web directory:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www\.)?newdomain\.com$ [NC]
RewriteRule ^(.*)$ http://www.existingdomain.com/$1 [R=301,L]
share|improve this answer
    
Forget the Options +FollowSymlinks as they belong to the Directory directive allowing to follow symbolic links which is a *nix file system item that does not have anything to do with Rewrite. I am sure it is a simple oversight, but I wanted to be careful to point this out. John knows what he is doing. –  closetnoc Apr 30 at 2:27
    
@closetnoc A copy and paste error. Thank you for pointing that out. –  John Conde Apr 30 at 2:32
    
Anytime. You have helped me and I know the quality of your answers. –  closetnoc Apr 30 at 2:42
    
@John Conde, you absolutely rock, thanks! –  Joe LaBarre Apr 30 at 14:08
    
@closetnoc: Options FollowSymLinks is actually required for mod_rewrite to work in per-directory .htaccess files - even on Windows. This is apparently a security requirement. The only time you don't need to explicitly set FollowSymLinks is if it is already enabled on the server (which it often is). Try Options -FollowSymLinks (to explicitly turn this off) and .htaccess/mod_rewrite is likely to break horribly (ie. a 403 when attempting to enable the rewrite engine: RewriteEngine On). –  w3d Apr 30 at 16:20
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.