Sign up ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I currently redirect all non-HTTPS connections to HTTPS, and support TLS v1, TLS v1.1, and TLS v1.2. I reconfigured my testing server to accept only a very limited and secure cipher suite and TLSv1.2 only. Upon running the SSL Labs test I noticed that their compatibility chart showed Bing's and Google's crawlers as not supporting beyond TLSv1.

Is this still accurate? I have not been able to find mention of the bots' protocol support anywhere except on the SSL Labs results page.

Does Googlebot really only support TLS v1?

If I support only TLS v1.2 and Googlebot is unable to connect to my site, what status will Google consider it to be in?

share|improve this question
I think you should take this question to the google webmaster forum.… –  Maelish Apr 29 '14 at 12:50
You should be able to test this yourself using the 'Fetch' within GWT no? –  Simon Hayter Apr 29 '14 at 13:13
I was unaware of 'Fetch' as I so very rarely enter GWT. I will investigate that method post-haste. –  Bryson Apr 29 '14 at 20:04

4 Answers 4

up vote 5 down vote accepted

As of September 14th, 2014, the Googlebot does NOT support TLS 1.2. You get notified about 100% inaccessibility and thats it. I am affected by this directly. Using TLS 1.2 SSL enforcement to get on my page.

Here is the proof that Google doesn't like to crawl TLS 1.2 pages as of now:

Google TLS 1.2

share|improve this answer
Please could you edit your question and include a link to the source backing this information up for future visitors. –  Simon Hayter Sep 14 '14 at 11:56
@bybe I tried to edit in a link but it wasn't accepted. Source:… –  dhaupin Dec 17 '14 at 14:29

Google should be able to handle all versions of SSL/TLS.

The best way to see how Google handles something is via Google Webmaster Tools.

Note: You have to have your site setup in Webmaster Tools for this to work. It's something you should consider anyway.

  1. Go to Webmaster Tools
  2. Select your site
  3. Select Crawl
  4. Select Fetch as Google
share|improve this answer

Google's crawl bots do not support TLSv1.2, this is fairly well known and people have ranted about Google's failure to support >TLSv1 for a while now as people have tried to make their website get a 100% score on places like SSLlabs -- which means they then get dropped off Google for unreachability.

TLSv1.2 is substantially different from TLSv1. This is a protocol name, not a software version. Any change in the number, even the dotX component, is a significant deviation. Protocols must not change, if they do, they must get a version change.

share|improve this answer

Please note: The version system of TLS like other products means the 1.X.X is Version 1. The 1.2 is usually reserved for updates, features, maintenance of the Version 1.

I would imagine that Google does have it supported, because they are pretty good at keeping up with the newest standards of security. What I can give proof of is all of the major browsers already support TLS 1.2

  • Chrome - v30 supports TLS 1.2. Previous to this only up to TLS 1.1 was supported
  • Firefox - v27 enables TLS 1.1 and 1.2 by default
  • Internet Explorer - v11 supports TLS 1.2 from Feb 2013
  • Opera - v17 has added support for TLS 1.2. Versions 10-12 supported TLS 1.1 and 1.2 but disabled it by default, and versions 14-16 supported TLS 1.1 but not 1.2.
  • Safari - v5 on iOS and v7 on OS X have added support for up to TLS 1.2.

I am going to say yes that Google Bot does support it just like Google Chrome does. I also do say if the browsers are supporting it, I say it is only a few lines of code changed for Google Bot to do support TLS 1.2 also.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.