Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am trying to update some plugins on a WordPress site. To do this directly through WordPress you need to provide:

  • Hostname
  • Username
  • Password
  • Connection yype

I am definitely using the correct details however they are being refused.

An error is displayed:

ERROR: There was an error connecting to the server, Please verify the settings are correct.

There is a thread on the WordPress forum asking similar question but there is no answer.

I have tried using my regular hostname in addition to localhost, localhost:21 and localhost:22.

Does anyone have any suggestions how to make this work correctly?

share|improve this question
    
are you using passive ftp? if so, does your server accept passive ftp? –  Liam Sorsby Apr 15 at 14:14
    
I believe it is using active mode. –  slaterio Apr 16 at 8:23

2 Answers 2

up vote 1 down vote accepted

If it were a folder permission error you would connect but get an error about permissions.

First enable WP_DEBUG in wp-config

If you have root access, check your php error log, and syslog in /var/log

From a shell, try FTPing to localhost does it work? Can you read and write to your plugins folder? Now also try from a remote machine FTPing into the server and again checking your read/write permissions.

Try setting the FTP details in wp-config

define( 'FS_METHOD', 'ftpext' );
define( 'FTP_BASE', '/path/to/wordpress/' );
define( 'FTP_CONTENT_DIR', '/path/to/wordpress/wp-content/' );
define( 'FTP_PLUGIN_DIR ', '/path/to/wordpress/wp-content/plugins/' );
define( 'FTP_PUBKEY', '/home/username/.ssh/id_rsa.pub' );
define( 'FTP_PRIKEY', '/home/username/.ssh/id_rsa' );
define( 'FTP_USER', 'username' );
define( 'FTP_PASS', 'password' );
define( 'FTP_HOST', 'ftp.example.org' );
define( 'FTP_SSL', false );

http://codex.wordpress.org/Editing_wp-config.php#WordPress_Upgrade_Constants

Figure out why you can't connect first. Then move on to folder permissions which is much easier to debug.

If you still have trouble just use this plugin http://wordpress.org/plugins/ssh-sftp-updater-support/

Keeping your WordPress install up-to-date and installing plugins in a hassle-free manner is not so easy if your server uses SFTP. "SSH SFTP Updater Support" for WordPress uses phpseclib to remedy this deficiency.

share|improve this answer

Check your file and folder permissions and set them to the correct ones. Have a look here. http://www.electronicworkplace.com/latest-updates/wordpress-correct-permissions-for-files-and-folders If you have the correct permissions then it won't ask you for ftp details.

If that doesn't work perhaps you have an ownership problem.

The other way to update is to manually upload the plugins to the plugins directory and update it that way.

share|improve this answer
    
Thanks for the link. My permissions were fine except for .htaccess file which I've now changed. I've eventually uploaded the individual plugins manually. Looking into ownership issues now. –  slaterio Apr 16 at 8:20
    
@slaterio any luck? –  Abu Nooh Apr 16 at 22:43
    
I haven't uncovered anything unusual in the settings/permissions yet. –  slaterio Apr 21 at 13:51
    
If you have a VPS and WHM make sure you're using suphp instead of DOS. That will get rid of all your file permission issues. –  gdaniel May 16 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.