Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

local install of wp site brought down from host - home page is ok but other pages redirect to wamp config page.

I got all local files from host to www dir under local wamp. I got database from host and loaded to new local db and used this tool to adjust site_on_web.com to "localhost/site_on_local"

now the home page works great and can login to admin page but when click on reservations page and others of site then site just goes to the wamp server config page even though the url shows correctly as localhost/site_on_local/reservations

my htaccess file is this

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

and rewrite-module is checked in the php-apache-apache modules setting. now when I uncheck the rewrite-module is checked in the php-apache-apache modules setting or I clear out the whole htaccess file then the pages just goto

Not Found
The requested URL /ritas041214/about-ritas/ was not found on this server.

Please help as I am unsure now about my process to move local site up and down and be able to make it work and without this I am lost...

share|improve this question
    
is mod_rewrite enabled? –  edvinas.me Jun 13 at 7:36
    
try resetting your permalinks to original and see if that helps. –  Abu Nooh Jun 13 at 21:42

2 Answers 2

Check wp-config.php to make certain it has all the right configuration settings in place, as well as any other information it may need, such as DB name, access and the like.

share|improve this answer
    
I checked the wp-config file and the db name and table prefix is ok and the localhost is connecting to the db ok since I am getting the home page just fine but the other problems noted in my original post are still there and can not solve this after many hours of trying, please help me..... thanks –  jeff Apr 14 at 20:01

Can you still access /wp-admin ? I fixed mine when it was doing this after migration by going to /wp-admin -> Permalinks -> set to the default (simple) page_id and then back to my date structure. This recreated the mod rewrite rules and it was OK after that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.