Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I copied a bunch of examples online to create my own custom UCP page/module. And it worked. But it only shows up for administrators.

I checked the ACP and there does not seem to be any settings there for permissions for any of the modules.

I skimmed the code and found:

 return array(
    'filename' => 'ucp_nhl',
    'title'    => 'UCP_NHL',
    'version'  => '1.0.0',
    'modes'    => array(
    'nhl' => array('title' => 'NHL', 'auth' => 'acl_a_user', 'cat' => array('UCP_LEAGUE'))),
    );

'auth' => 'acl_a_user' jumped out, but there does not seem to be a single resource online as to what that means. I checked the other UCP pages and they mostly use 'auth' => '' so I switched to that. But it still only shows up for administrators. What am I doing wrong? Is there some refresh thing I have to do, I tried disabling and enabling the module, but that had no effect.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.