Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I'm new to the world of webmasters, so I haven't been able to appropriately search for an answer. I don't know the keywords that describe my situation.

I registered hallienoelle.com and the .net version through GoDaddy and set up forwarding with masking to hallienoelle2.wpengine.com.

When you go to the .com or .net, it takes you to the homepage with no slashes or anything after it. If you click on a different page, it takes you to that page, but doesn't change the url. It still says hallienoelle.com with no slashes or anything after it.

The most worrisome part is that if someone clicks an external link my URL is still in the address bar.

For example, clicking the Powered by Wordpress link at the bottom takes you to wordpress.org, but the address bar still shows hallienoelle.com with no slashes or anything after it .

Did I do something wrong in setting up GoDaddy forwarding or is it a Wordpress/WPEngine configuration issue?

UPDATE: Thanks to PatomaS I know how to fix the external link problem. I still am unsure of how to get the directory/folder/webpage to display after the .com like so:

  1. Go to hallienoelle.com (and see the content from hallienoelle2.wpengine.com)

  2. Click a link, like About Us

  3. This should take you to hallienoelle.com/?page_id=11 (and you see the content from hallienoelle2.wpengine.com/?page_id=11)

  4. But, currently it still shows just hallienoelle.com even though you are looking at the ?page_id=11 page.

Do I have to go through all my internal links and hard-code something like <a href="hallienoelle.com/?page_id=11" target="_top">About Us</a>?

This seems inefficient and error prone. I'm probably just misunderstanding something.

UPDATE 2: WPEngine also gives me the option of forwarding to http://198.58.98.52/ and I (think) it reads the requested URL from the header and serves my content.

I add this because as I've been reading someone said redirects to mysite.example.com are generally used for free hosting providers and are looked down upon. I use hallienoelle2.wpengine.com because it is recommended on http://wpengine.com/support/how-to-configure-your-dns/ under the heading Setting up a subdomain.

share|improve this question
    
Do you want to keep your URL without wpengine? Can you move all your content to your site, and not use wpengine? –  PatomaS Mar 3 at 0:33
    
@PatomaS I'm intentionally using WPEngine because they're very good about Wordpress security and I can focus my limited time on other aspects. "Do I want to keep my URL without wpengine?" I'm sorry, I don't understand. Could you rephrase that? –  Z_AHK Mar 3 at 1:05
    
No need to rephrase, you already answered. If you want to keep the site on wpengine, but show the other url, then masking is a good option, but you have to take care of the external links, read my answer below. –  PatomaS Mar 3 at 1:07

1 Answer 1

up vote 0 down vote accepted

Checking you code, we can see that you have this:

<frameset rows="100%,*" border="0">
  <frame src="http://hallienoelle2.wpengine.com" frameborder="0" />
  <frame frameborder="0" noresize />
</frameset>

I suppose that is the masking part of the setting on GoDaddy that you mention.

Which means that you are using frames on your site. All the content is on the lower frame, the one that says <frame frameborder="0" noresize />. and your links are normal one, like this:

Powered by <a href="http://www.wordpress.org">WordPress</a>

you have to change that link to something like this

Powered by <a href="http://www.wordpress.org" target="_top">WordPress</a>

or

Powered by <a href="http://www.wordpress.org" target="_parent">WordPress</a>

Although both options work slightly different, there is no difference in your actual situation.

Update

Since all the pages/resources from http://hallienoelle2.wpengine.com/ are inside the frame in hallienoelle.com, you can not see any change in the URL bar.

All the links from http://hallienoelle2.wpengine.com/ will work normally, but the idea of the masking, is to keep the hallienoelle.com on the URL, all the time.

When you edit your code or pages on http://hallienoelle2.wpengine.com/ or when you add more content there, don't worry about the other address, just do all the editing and linking as if hallienoelle.com didn't exist. In fact, for http://hallienoelle2.wpengine.com/, hallienoelle.com doesn't exist. It's just a concept on our mind as users.

share|improve this answer
    
Thank you! Your solution works perfectly for external links. It also works for hard-coded internal links like http://hallienoelle2.wpengine.com/?page_id=13, but that is sub-optimal. At this point, we (you) have established it's because of GoDaddy's frames. Should I keep searching and/or contact WPEngine for a way to have them display hallienoelle.com/?page_id=13 or is that not possible? –  Z_AHK Mar 3 at 1:20
    
Your question is not clear. If you want to have your content on hallienoelle2.wpengine.com but show it on wpengine.com, your easiest option is to use frames, as you are doing now. All the links from hallienoelle2.wpengine.com without a target="_top" are going to be on the frame, which is what you want. If you want any specific link to behave different, please update the question and explain what you want so we can answer that. –  PatomaS Mar 3 at 1:29
    
I updated the question. I don't know if you get notified about that, so I'm commenting. Thank you for your help again! –  Z_AHK Mar 3 at 1:53
    
Thank you for your help! I would upvote you, but I don't have enough rep. –  Z_AHK Mar 3 at 2:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.