Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am developing a strategy game for web where there there will be a lot of client-server traffic for sending attacks, moves, etc. Right now I send messages from the client to the server via HTTP, and I want to try and setup SSL on my Ubuntu server which already has a LAMP stack installed and running.

Here are the guides I've followed:

After I installed the keys, I tried hitting my page using the https:// prefix, but I got an error:

SSL connection error. Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have. Error code: ERR_SSL_PROTOCOL_ERROR

After I received this error, I tried following: https://www.debian-administration.org/articles/349

This lead me around to modifying my 'ports.conf' file which now looks like:

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>

I restarted Apache successfully, and I can still hit my pages using HTTP, but not HTTPS (receiving the same error as before).

What step(s) am I missing?

share|improve this question
    
do you have any certificate installed, even a trial one created by yourself? –  PatomaS Feb 24 at 6:29
    
have you read Ubuntu - HTTPD - Apache2 Web Server? or Apache2 SSL in Ubuntu? Or any other tutorial/manual/wiki explaining the process? –  PatomaS Feb 24 at 6:32
    
Reading your question and the Ubuntu documentation I don't see the step where the ssl module is enabled. Possibly dumb question, but have you run sudo a2enmod ssl yet? No harm in running the command a second time to check. Also, I've found the DigitalOcean documentation for setting up SSL to be easier to follow and more complete. –  Tom Brossman Feb 24 at 9:45
    
PatomaS: Yep, I created the certs and installed them, but I have not read your links yet. TomBrossman: I think I ran that command once before and it said it was already enabled, but I will check again. I am going to read each of the links provided and update my OP after I've tested them. Thanks for the responses! –  Storm Kiernan Feb 24 at 15:17
1  
The solution was in digitalocean.com/community/articles/… I needed to perform the command: $ sudo a2ensite default-ssl If you post the answer I will mark it. –  Storm Kiernan Feb 25 at 2:52

1 Answer 1

up vote 3 down vote accepted

The solution was located in digitalocean.com/community/articles/. I needed to perform the command: $ sudo a2ensite default-ssl

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.