Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have recently updated a website for a friend and found that the WordPress 'Hello World' page was showing in Google results. I used the URL removal tool and asked for this to be removed, however it removed the homepage so now it is not showing in Google, only the Hello World one is.

I went back in and 'Cancelled' the request but it is still not showing, do I need to do anything else?

share|improve this question
    
You're not blocking search engines in Wordpress are you? Your homepage shouldn't have been removed from Google's index unless you left the field blank in the URL removal tool in Google WMT. –  zigojacko Feb 11 at 10:03
    
my robots.txt has the following:User-agent: * Disallow: /wp-admin/ Disallow: /wp-includes/ and my sitemap has 4 pages listed which Webmaster Tools says 4 have been submitted but nothing for indexed. I submitted the 8th and it says processed 10th. –  Guestz81 Feb 11 at 10:11
    
What's the URL of your website? –  zigojacko Feb 11 at 10:32
    
Link to the website from Google+. That should get it indexed again quickly - there doesn't appear to be an issue at present, probably Googlebot isn't visiting your website frequently so it's a case of giving it some more time. –  zigojacko Feb 11 at 10:40
    
OK, Thanks for help Geoff. I wondered if I was just being impatient. I'll give it a bit more time. With regards to the Google+ account, can it be any or would it need to be associated with the site? Just out of interest, why might this get it indexed quickly? –  Guestz81 Feb 11 at 10:42

1 Answer 1

Your problem seems to be meta tags on your site which tell Google not to index it. Line 25 in your source code states:

<meta name="robots" content="none" />
<meta name="googlebot" content="none" />

If you remove those tags and resubmit the pages for indexing in Webmaster Tools then you should get back in the index soon enough.

share|improve this answer
    
Sorry, do you know how I remove these lines? I'm using Yoast SEO Plugin in Wordpress, I can only presume I have set something in there that is causing the issue. –  Guestz81 Feb 11 at 16:05
    
I dont know exactly, try disabling the plugin and seeing if that removes the tags, and if it does then at least you know exactly where to look further. –  user29671 Feb 11 at 17:31
    
Try settings -> reading -> search engine visibility (Documentation) –  Stephen Ostermiller May 13 at 2:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.