Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I want to create SEO friendly URL for my website. I am creating a .htaccess file but these file not run in Bluehost. Bluehost gets an "Internal Server Error":

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ompeespace.coraltechnologies.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

I can't understand what did I do.

share|improve this question

migrated from webapps.stackexchange.com Feb 8 at 14:58

This question came from our site for power users of web applications.

5  
You have a syntax error in your htaccess file. Post it here so we can see it and try to troubleshoot it for you. –  John Conde Feb 8 at 14:59

3 Answers 3

Rewriting (via .htaccess) in a user directory (if not globally enabled) requires two settings in the Apache config. One is to allow the usage of .htaccess files via the AllowOverride directive. This seems to be the case already, as you receive the HTTP 500 after adding the rewrites.

Second directive to be set is the Options +FollowSymLinks, otherwise a HTTP 500 is presented (you might wanna check: https://httpd.apache.org/docs/current/mod/mod_rewrite.html#rewriterule).

If this also isn't the case, then it might be (as mentioned by John Conde) a syntax error in your Rewrite rules or your .htaccess file.

share|improve this answer

I had implemented URL rewriting using .htaccess on Bluehost server a way back. Can't find exact code in my previous company project works but this article will help you a lot. I am sure it's syntax error because Apache will not show you user friendly error specially for .htaccess.

share|improve this answer
    
right bro this is error in .htaccessfile. ompeegroup.com –  jeet sejwal May 20 at 9:54
    
m glad it helped :) –  Harmeet Bhamra May 22 at 5:45

Also, check the permissions on the .htaccess file, usually you upload a .htaccess with 777 permissions, and most hosts only run with 644

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.