Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I recently completely redesigned my website, http://concourstee.fr. We used to have a fairly good ranking in Google, but when redesigning the website I thought I'd try to make things better. (WordPress Yoast plugin for SEO, better use of keywords, etc.)

So I moved the old website to http://concourstee.fr/old/ and uploaded the new version of the website. (Both versions are running WordPress)

Since then, my website has just completely disappeared from Google, I have absolutely no idea why... I realized that Google only found the old website, under concourstee.fr/old/ when doing a search for site:concourstee.fr, so I moved it downloaded a backup of the old website and deleted it. Google can still only find concourstee.fr/old/, about a week afterwards, and it still won't display the new website, even when searching for things as basic as "Concours Total EDHEC Entreprendre", which is the actual name of the site, and appears several times on the main page.

I then realized I had an error in my code :

<meta name="robots" content="none" />
<meta name="googlebot" content="none" />

Which I fixed two days ago, changing none to index,follow, but I am still not appearing in Google...

So what am I to do? We have a big event coming up and we really need our Google visibility back!

share|improve this question
    
Just for information, none value as content for this meta tag is invalid and index, follow is the default value. Therefore, you can just remove the meta tag. –  Zistoloen Jan 30 at 10:52
    
content="none" does the same as noindex,nofollow for the record. –  zigojacko Jan 30 at 10:56
    
I know but it's not a valid value (source). –  Zistoloen Jan 30 at 11:02
    
The Wordpress theme I was using had "none" as a default value, no idea why anyone would want that as a default... –  Mark Hadj Hamou Jan 30 at 11:16
1  
@Zistoloen Your source doesn't actually say it is not a valid value, it just doesn't mention it. Regardless of whether it is "valid" or not, the fact is, usage of it, does do something - completely deindexes a website so whether it is valid or not is irrelevant. Google claim it to be a valid tag with the equivalent of noindex, nofollow. –  zigojacko Jan 30 at 11:18
show 1 more comment

2 Answers 2

The disallowing of indexing/following with the <META NAME="ROBOTS" CONTENT="NONE"> will be the reason that your website disappeared from Google's index. You've since amended this but you'll have to wait for GoogleBot to revisit your website, crawl all pages and reindex them again now. You can speed up this process with:-

  • Linking to your website from somewhere else (anywhere), ideally a followed link.
  • Submitting your sitemap to Google Webmaster Tools.
  • Pinging your sitemap using a service such as this one.
  • +1'ing (sharing) some pages from your website on Google+.

It would also be recommended to prevent everything at /old from getting indexed by either:-

  • Manually requesting the removal of each URL in Google Webmaster Tools.
  • Inserting a <META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW"> into the <head> on the entire /old directory.
  • Adding a disallow directive in your robots.txt such as Disallow: /old/
share|improve this answer
    
Thanks a lot for the fast reply ! I have quite a few people linking back to my site, partners and such, I've received quite a few links as of late. I resubmited my sitemap and used that ping tool (although only Google and Bing were notified for some reason ?). I'll share on Google° ASAP. As for /old/, I deleted the folder, and added Disallow: /old/ on my main robots.txt, how long before Google understands and removes /old/ ? I have many search results under /old/, do I really have to go through each link and ask for their removal ? –  Mark Hadj Hamou Jan 30 at 11:11
    
If you've deleted /old from the server now, it shouldn't take Google too long to remove this from their index depending on how frequently they visit your website. You could just 301 redirect everything at /old to the / instead in the meantime while you wait for Google to update it's index. –  zigojacko Jan 30 at 16:01
add comment

In your case, I guess you have a duplicate content issues between old and new site. Google doesn't know which site it must display in its index. That's why when you type site:concourstee.fr on Google, you find some URLs from the old site and others from the new site (for your information, if Google discovered the old site, this is because Googlebot found a link to it, thus check your new site links don't point to the old one).

To fix your problem, you can remove the old/ folder, return 410 HTTP status for all old URLs and block the folder in your robots.txt. Then, you can let Google removing old URLs by its own (410 HTTP status is here for this) or ask removal from your Google Webmaster Tools account; in two cases, it takes time (can be weeks or months) to remove all old URLs from Google index. By following this procedure, you should see the new site URLs showing up in Google index because your duplicate content issues will have gone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.