Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

i have a probelm with this configurations, only the first virtual host is working and other under the same domain point to the first www.firebuggger.com).

do you guys have a clue?

NameVirtualHost *:8080

<VirtualHost *:8080>
ServerName www.firebuggger.com
DocumentRoot "/home/eben/domains/firebugger.com/html"
</VirtualHost>

<VirtualHost *:8080>
ServerName blog.firebuggger.com
#ServerAlias blog.firebuggger..com
DocumentRoot "/home/eben/domains/blog.firebugger.com/html"
</VirtualHost>

<VirtualHost *:8080>
ServerName www.firebuggger.com
#ServerAlias firebuggger.com
DocumentRoot "/home/eben/domains/firebugger.com/html"
</VirtualHost>


<VirtualHost *:8080>
ServerName wordpress.firebuggger.com
DocumentRoot "/home/eben/domains/wordpress.firebugger.com/html"
</VirtualHost>
share|improve this question

closed as unclear what you're asking by Stephen Ostermiller Jan 17 at 17:01

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

    
Why the entry with ..com? That looks wrong to me. –  Stephen Ostermiller Jan 21 '14 at 19:03
1  
Have you enabled virtual hosts in config? –  Pazis Jan 21 '14 at 20:29
    
..com was a typo. i fixed it by changing * to default –  eben Jan 21 '14 at 21:09
1  
Have you set the sites in site enabled (Ubuntu) and have you restarted apache? –  Liam Sorsby Jan 22 '14 at 8:25